ABCelectronique : portail d'information dans le domaine de l'électronique

Merci de ne pas poster des messages en relation avec le piratage.


    Forums de Abcelectronique > Electronique Analogique et Numérique
  » Mesure de courant sur signal spécial
Identifiant Se souvenir de moi ?
Mot de passe
Répondre     Nouvelle discussion
Mesure de courant sur signal spécial

 

Partoutatis
Partoutatis ☆☆☆☆☆☆ 16/03/2017, 10h48 #1  
Bonjour tout le monde,

J'aurais besoin de votre aide pour réaliser une carte de gestion suivant ce principe :

- Elle sera composée d'un oscillateur d'environ 100Hz avec un rapport cyclique de 50% (pour diminuer la luminosité des LED) La sortie de cet oscillateur pourra être connecté ou déconnecté.

- Elle sera composée d'un deuxième oscillateur d'environ 0.5Hz avec un rapport cyclique de 50% (pour faire clignoter les LED) La sortie de cet oscillateur pourra être connecté ou déconnecté.

- De 3 à 5 groupes de LED qui peuvent consommer entre 10 mA et 500 mA

- Chaque groupe de LED aura sa propre mesure de courant réalisée avec des AOP. Le but sera de déclencher un relais quand la consommation aura diminuée de 50% environ suite à des LED grillées ou des fils arrachés etc.

Fonctionnement :

- Cas N°1 : les LED sont allumées en continu, 24V.
- Cas N°2 : on vient à commuter l'oscillateur 0.5 Hz : les LED clignotent
- Cas N°3 : on vient à commuter l'oscillateur 100Hz : les LED diminuent en puissance (mode nuit)
- Cas N°4 : on vient à commuter les 2 oscillateurs : les LED diminuent en intensité lumineuse et clignotent.

Jusque là c'est facile à faire (voir synoptique). Les oscillateurs seront réalisés avec des NE555.

Là où ca se complique c'est pour la mesure de courant. SI j'ai une carte LED qui consomme 50 mA, il faut que je remonte une alarme si la conso devient inférieur à 25 mA. Seuil réglable avec un potar. Facile à faire en continu.
Par contre si je viens à commuter les oscillateurs, comment "adapter" la mesure de courant pour pas qu'elle me remonte un défaut (puisque la conso va forcément diminuer mais c'est volontaire et non une panne).

- Le temps de réponse de l'alarme peut être d'une ou 2 secondes (pas vraiment d'importance)
- En mode clignoteur, si mon alarme "clignote" c'est acceptable.

Bien évidemment, le tout doit être en analogique et ou circuit logique mais pas de µC.

Si vous avez des idées, ca serait super ! Merci et bonne journée !
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  synoptique.png
Affichages : 39
Taille :  25,3 Ko Cliquez sur l'image pour la voir en taille réelle

Nom :  synoptique_2.jpg
Affichages : 23
Taille :  210,2 Ko
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 16/03/2017, 10h52 #2  
devoir à rendre quand ? ;)
DAUDET78
DAUDET78 ★★★★★★★ 16/03/2017, 11h09 #3  
- Tu mets un NMOS par guirlande LED
- Tu mets une résistance dans la source du NMOS pour avoir une image du courant
- Un comparateur détecte la diminution du courant
YaPuKa
PS : Un CD4011 pour driver un NMOS ..... pas terrible !
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 16/03/2017, 11h12 #4  
le projet est foireux dés le début AMHA en utilisant des soluces du siècle dernier (1970)
DAUDET78
DAUDET78 ★★★★★★★ 16/03/2017, 11h23 #5  
Non, c'est possible
Posté par Partoutatis

Par contre si je viens à commuter les oscillateurs, comment "adapter" la mesure de courant pour pas qu'elle me remonte un défaut (puisque la conso va forcément diminuer mais c'est volontaire et non une panne).

par contre cette affirmation est erronée et montre une méconnaissance des notions de courant
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 16/03/2017, 11h38 #6  
Il ne s'agit pas du tout d'un devoir, c'est un projet perso.

Le courant moyen alors. Et c'est ce qu'on mesure...
DAUDET78
DAUDET78 ★★★★★★★ 16/03/2017, 11h56 #7  
Posté par Partoutatis

Le courant moyen alors. Et c'est ce qu'on mesure...

Non ,
Le comparateur mesure le courant crête qui est indépendant du PWM de la luminosité !
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
dspix
dspix ★★★★★★★ 16/03/2017, 12h27 #8  
A 100Hz le scintillement peut être perceptible... Autant haché a vitesse plus élevé... (> 200Hz).
__________________
A+
Damien
Partoutatis
Partoutatis ☆☆☆☆☆☆ 16/03/2017, 13h17 #9  

Non ,
Le comparateur mesure le courant crête qui est indépendant du PWM de la luminosité !



OK mais il faut que je passe par un filtre RC non ? J'ai fais la manip et j'obtient 12V de moyenne (quand j'alimente avec un carré de 24V 50%) donc au lieu d'avoir 24V qui traverse la résistance de 4,7 ohms, j'ai 12V donc le courant est divisé par 2...

A 100Hz le scintillement peut être perceptible... Autant haché a vitesse plus élevé... (> 200Hz).



Idem, j'ai déjà fais le test et à partir de 75 Hz on voit plus rien.
DAUDET78
DAUDET78 ★★★★★★★ 16/03/2017, 13h26 #10  
Posté par Partoutatis

OK mais il faut que je passe par un filtre RC non ?

Non ....
Un réseau RC te donne la valeur moyenne ( qui est fonction du PWM ET du nombre de LED H.S.)
Avec une détection de la valeur crête, tu ne tiens pas compte du PWM .
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 16/03/2017, 14h17 #11  
Ah d'accord en plus c'est logique.
Un détecteur de crête se réalise avec un AOP et une diode c'est bien ca ?
DAUDET78
DAUDET78 ★★★★★★★ 16/03/2017, 14h26 #12  
Posté par Partoutatis

Un détecteur de crête se réalise avec un AOP et une diode c'est bien ca ?

Non, avec un comparateur !
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 16/03/2017, 14h39 #13  
Euh y'a un truc que je pige pas là... si je rentre un signal carré dans mon comparateur, j'en ressors un signal carré et je me vois mal piloter un relais avec ca.
DAUDET78
DAUDET78 ★★★★★★★ 16/03/2017, 16h32 #14  
Posté par Partoutatis

Euh y'a un truc que je pige pas là... si je rentre un signal carré dans mon comparateur, j'en ressors un signal carré

Un signal rectangulaire! C'est un PWM variable pour faire varier la luminosité de tes LEDs

et je me vois mal piloter un relais avec ca.

ben moi, je vois très bien !
Cogite un peu :
- Tu dépasses régulièrement le seuil (car les LEDs sont OK à plus de 90%) , tu as des pulses en sortie
- Tu ne dépasses plus le seuil (car les LEDs sont HS à 50%) , tu n'as plus de pulse en sortie

Faut rajouter quoi pour transformer ces deux états en signal On/Off ?
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
DAUDET78
DAUDET78 ★★★★★★★ 16/03/2017, 18h26 #15  
Mon jour de bonté .....
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  LED_Noel.JPG
Affichages : 38
Taille :  19,4 Ko
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 17/03/2017, 08h07 #16  
Bonjour DAUDET78, je suis d'accord avec toi, hier je n'ai pas assez cogité et je m'en rends compte en relisant le sujet.

Heureusement que tu as des jours de bonté :) Du coup je commence un schéma et je le poste en fin de matinée si j'y arrive.

En attendant, Merci !
DAUDET78
DAUDET78 ★★★★★★★ 17/03/2017, 08h14 #17  
Fait un schéma par bloc

Des bases de départ :
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  NE555_50-50.JPG
Affichages : 24
Taille :  25,1 Ko Cliquez sur l'image pour la voir en taille réelle

Nom :  NE555_Missing_Pulse.jpg
Affichages : 26
Taille :  24,9 Ko Cliquez sur l'image pour la voir en taille réelle

Nom :  NE555_PWM-Lampe-12V.jpg
Affichages : 23
Taille :  18,4 Ko
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !

Dernière modification par DAUDET78 17/03/2017 à 08h24.
Partoutatis
Partoutatis ☆☆☆☆☆☆ 17/03/2017, 11h11 #18  
C'est ce que je fais :)

PS : le monostable joue le rôle de watchdog en gros c'est ça ?
DAUDET78
DAUDET78 ★★★★★★★ 17/03/2017, 11h20 #19  
Posté par Partoutatis

le monostable joue le rôle de watchdog en gros c'est ça ?

Exact
Tant qu'il y a des pulses, il sort un niveau "1" . En cas d'absence, il sort un niveau "0"
Il faut le régler un peu plus grand que la période d'inactivité
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 21/03/2017, 17h52 #20  
Bonjour,
Quelques soucis m'ont empêché de terminer le schéma et donc de le poster en tant voulu. Je termine demain dans la journée.
Partoutatis
Partoutatis ☆☆☆☆☆☆ 22/03/2017, 16h14 #21  
Voilà les 2 oscillateurs.

Le premier à 0.5Hz environ me permet de faire clignoter ou flasher les LED en fonction de la position du potar P1.

Le deuxième me permet de faire varier la luminosité avec une fréquence de 170Hz environ avec un rapport cyclique allant de 10 à 90%. Il ne faut pas que je puisse éteindre complètement les LED ou les allumer à pleine puissance. Il sera affiné par la suite en fonction de mes essais.

Reste à mélanger les 2.
Faire le mesure de "courant"
Et faire le monostable. (c'est en cour)
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  oscillateurs.png
Affichages : 14
Taille :  6,2 Ko
DAT44
DAT44 ★★★★★☆☆ 22/03/2017, 17h42 #22  
Bonjour,
pour le mélange, tu peux connecter la sortie(mettre un résistance de pull-up) du 0,5 Hz sur le /RES du 170 Hz ...
__________________
Il ne faut pas cracher face au vent !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 22/03/2017, 19h34 #23  
Bonsoir DAT44, effectivement c'est ce que j'ai pus observer sur les schémas des sirènes d'alarme américaines. J'essaye ca demain.
Partoutatis
Partoutatis ☆☆☆☆☆☆ 23/03/2017, 08h27 #24  
Donc voilà ce que j'ai fais (voir le schéma joint).
J'obtient bien en sortie OSC2, un PWM cadencé à 0.5Hz : parfait.

Par contre, comment désactiver l'un ou l'autre oscillateur à la demande ?

C'est pour ca que j'étais partis à la base sur une porte logique pour balancer en entrée ou non (à l'aide d'un relais miniature) un des 2 oscillateurs ou les 2.

Rappel : il faut que je puisse soit :

- Laisser allumé les LED en continu à pleine puissance (donc aucun 2 des oscillateurs n'entre en action, les 2 entrées TOR sont inactives),
- Baisser la luminosité de moitié sur demande à l'aide d'une entrée TOR,
- Faire clignoter les LED à l'aide d'une deuxième entrée TOR,
- Et enfin, si les 2 entrées TOR sont actives, alors le signal clignote et baisse en luminosité (les 2 oscillateurs entrent en action)
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  oscillateurs_2.png
Affichages : 12
Taille :  6,7 Ko
Partoutatis
Partoutatis ☆☆☆☆☆☆ 23/03/2017, 15h00 #25  
Dernier montage, j'ai ajouté un monostable de 1.1 seconde et un mélangeur à base de portes logiques NAND.
J'avais que des NAND de dispo pour faire un essais.

Tout fonctionne. Tant que j'ai un des 2 signaux le monostable garde un niveau haut en sortie.
Si les 2 sont coupés, alors le monostable me sort un niveau bas.

Reste à ajouter la mesure de courant entre les deux.
On est d'accord sur le fait que je dois mettre un AOP du genre TL082 pour amplifier la tension du shunt, et qu'ensuite je rentre dans un comparateur du genre LM339 ?
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  oscillateurs_03.png
Affichages : 17
Taille :  9,9 Ko

Dernière modification par Partoutatis 23/03/2017 à 15h44.
DAT44
DAT44 ★★★★★☆☆ 23/03/2017, 22h34 #26  
Bonjour,
normalement le monostable il est activer par la détection de courant, non ?
__________________
Il ne faut pas cracher face au vent !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 25/03/2017, 10h30 #27  
C'est exacte, mais j'essaye de faire chaque chose, une par une comme me l'a dit DAUDET.
maî
maî ★★★★★☆☆ 26/03/2017, 10h13 #28  
bonjour

Tu as regardé du cote fréquence secteur pour le 100Hz et avec diviseur(2) par 10 ou + ou - pour le clignotement de tes LED et pour le monostable un 4538 par exemple. Avantage moins de composants, c'est qu'une piste .Enfin si tu as du secteur bien sur.

A+
__________________
le souffle du vent passe ...........

Dernière modification par maî 26/03/2017 à 10h48.
Partoutatis
Partoutatis ☆☆☆☆☆☆ 26/03/2017, 13h16 #29  
Je n'y avais pas pensé mais de toute façon je n'ai pas de secteur mais seulement du 12V ou 24V continu.
maî
maî ★★★★★☆☆ 26/03/2017, 14h03 #30  
la piste est fermé :-)

A+
__________________
le souffle du vent passe ...........
maî
maî ★★★★★☆☆ 26/03/2017, 14h14 #31  
Tient une autre piste, pour le courant ,des AOP dédies pour: les INA138,169 sympa, une résistance pour le contrôle du gain et affaire réglé et de plus sur le positif.

Allez A+
__________________
le souffle du vent passe ...........

Dernière modification par maî 26/03/2017 à 14h26.
Partoutatis
Partoutatis ☆☆☆☆☆☆ 29/03/2017, 11h28 #32  
Bonjour à tous,

Quel est la meilleur méthode à votre avis ?

1) Comparer directement la tension aux bornes du shunt avec une ref de tension réglable ? (allant de 47 mV / 2 à 2.35V / 2)
2) Ou d'abord amplifier le signal jusqu'à VCC/2 environ (2.5V) et ensuite le comparer à un comparateur à 50% ?

Rappel : le but étant de ressortir les signaux carrés seulement quand ils sont supérieurs à 50% de la consigne.

Dans le cas des 10 mA on a donc 47 mV aux bornes du shunt, tant que la tension du shunt est supérieur à 23 mV, on ressort les signaux. Si en dessous, on ne ressort plus rien.

Sachant que mon shunt de 4,7 ohms aura une tension allant de 47 mV (pour I = 10 mA) à une tension de 2.35V (pour I = 500 mA).
DAT44
DAT44 ★★★★★☆☆ 29/03/2017, 12h37 #33  
Bonjour,
en PWM le courant ne varie pas, c'est le rapport cyclique qui varie ...
__________________
Il ne faut pas cracher face au vent !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 29/03/2017, 13h19 #34  
Bonjour DAT44,

Je suis d'accord avec toi. Mais on est bien d'accord que durant le temps à l'état haut de chaque impulsions, la tension aux bornes du shunt est proportionnelle au courant consommé par ma carte. Si la moitié des LEDs de ma carte grillent, la tension à l'état haut aux bornes de mon shunt va diminuer puisque ma carte va consommer moins. Et c'est ce que je cherche à détecter : alarme si la conso baisse d'environ 50%.
SerDes
SerDes ★★★☆☆☆☆ 29/03/2017, 13h51 #35  
Salut,

tout depend quelle distance entre le point de mesure shunt (platine LED) et l'entree du bloc qui fait la detection de courant..si les deux sont proches (avec un meme plan gnd) alors on peut traiter directement la vingtaine de mV.
Partoutatis
Partoutatis ☆☆☆☆☆☆ 29/03/2017, 15h36 #36  
La distance sera faible car le comparateur sera aux pattes du mosfet et du shunt.
maî
maî ★★★★★☆☆ 29/03/2017, 17h14 #37  
Bonjour

Plutôt que d'utiliser un shunt, pourquoi ne pas utiliser, la résistance limite courant en série avec la LED pour déterminer justement ce courant, (c'est ici, le point de comparaison).
Encore une piste, mais bien sur aucune idée de comment sont câblées tes LED? sinon on ferme aussi cette piste.

A+
__________________
le souffle du vent passe ...........
DAT44
DAT44 ★★★★★☆☆ 29/03/2017, 21h47 #38  
Bonjour,
il faut que le comparateur (qui alimente le transistor a l’entré du monostable)compare la tension que fournis le shunt avec une tension deux fois inférieur a la tension que fournis nominalement le shunt (quand toutes des LEDs sont OK).

Par exemple:
Si le shunt fournis 100 mV (quand la sortie du PWM est à l'état 1), il faut que l'autre entré du comparateur soit a 50mV.
__________________
Il ne faut pas cracher face au vent !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 30/03/2017, 07h35 #39  
Bonjour,

Maï : Ce sont des cartes LED composées de plusieurs branches. Il peut y avoir 2 branches de 10 mA, comme 20 branches de 20 mA...

DAT44 : C'est exactement ce que j'ai fais. Le seul soucis rencontré sur ma plaque d'essais, c'est de pour avoir une tension de 25 mV (pas facile à régler, malgré un condo de 1µF pour stabiliser) mais aussi, je pense que le comparateur n’accepte pas une tension aussi faible à ses bornes. J'ai un LM311 ou un LM2903.
Parce que bien évidement, il faut que ma carte puisse s'adapter au cas ou j'ai une tension de 2.35V aux bornes du shunt.
Donc ma ref de tension doit pouvoir avoir une plage de réglage de 0V à 2V environ.
maî
maî ★★★★★☆☆ 30/03/2017, 08h02 #40  
Posté par Partoutatis

mais aussi, je pense que le comparateur n’accepte pas une tension aussi faible à ses bornes. J'ai un LM311 ou un LM2903.
Parce que bien évidement, il faut que ma carte puisse s'adapter au cas ou j'ai une tension de 2.35V aux bornes du shunt.
Donc ma ref de tension doit pouvoir avoir une plage de réglage de 0V à 2V environ.



peut-être passé avec des INA139,ils sont fait pour cela sur shunt placé sur le positif ou alors il doit bien en avoir d'autres

allez la DS du 139 http://www.ti.com/lit/ds/symlink/ina139.pdf

A+
__________________
le souffle du vent passe ...........
SerDes
SerDes ★★★☆☆☆☆ 30/03/2017, 08h49 #41  

je pense que le comparateur n’accepte pas une tension aussi faible


il n'y a pas de secret, c'est indiqué dans la ds.
par exemple la version 'A' du LM2903 serait plus indiquée avec un offset de 1mV (typ) et 4mV (max) ce qui parait acceptable pour ton appli.
Ne pas oublier le pull-up.
Tu alimentes comment (tension symetrique ou single supply) et combien?
Partoutatis
Partoutatis ☆☆☆☆☆☆ 30/03/2017, 11h21 #42  
Le comparateur est alimenté en 12V non symétrique.

Bon tout mon système fonctionne bien ! J'ai revu mes valeurs de shunt en les passant à 10 ohms pour les faibles conso, et 1 ohm pour les plus grosses. Cela me permet d'avoir des tensions de ref facilement réglables.

Par contre j'ai remarqué que quand ma tension aux bornes du shunt est de 130 mV, quand je la connecte sur l'entrée du comparateur, elle augment à 214 mV. A vide j'ai 300 mV... du coup ca me fausse les mesures...

Pour ma ref de tension j'ai mis un LM336 à 2.5V suivi d'un potar dans un pont diviseur. Pour 130 mV j'ai réglé à 130/2 soit 65 mV. Mais le comparateur me rajoute un déchet.
DAUDET78
DAUDET78 ★★★★★★★ 30/03/2017, 11h48 #43  
Redonnes ton schéma actuel
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 30/03/2017, 15h51 #44  
Bonjour DAUDET,

Voilà le schéma actuel.
J'ai intégré une de mes cartes LED qui donne une tension de 144 mV aux bornes du shunt de 1 ohm.
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  oscillateurs_04.png
Affichages : 12
Taille :  53,0 Ko
DAUDET78
DAUDET78 ★★★★★★★ 31/03/2017, 00h58 #45  
- Ce schéma devrait être un peu plus fonctionnel (sauf erreur de ma part)
- Ton monostable ne correspond absolument pas avec ce que je t'ai indiqué en #17 ! Copie à revoir
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  oscillateurs_04.JPG
Affichages : 11
Taille :  100,9 Ko
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 31/03/2017, 11h05 #46  
Nouveau schéma.
Le premier oscillateur 0.5Hz doit être ajustable au niveau du rapport cyclique pour faire soit un clignotement, soit un "flash".
Les entrées BP sont remplacées par des relais qui seront piloté via un automate.

J'ai également rajouté un capteur de lumière car, soit le montage sera autonome, soit on pourra forcer avec le relais. Par contre ilo n'est pas relié au reste... je cherche.
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  oscillateurs_05.png
Affichages : 11
Taille :  54,4 Ko
DAUDET78
DAUDET78 ★★★★★★★ 31/03/2017, 11h53 #47  
Posté par Partoutatis

Le premier oscillateur 0.5Hz doit être ajustable au niveau du rapport cyclique pour faire soit un clignotement, soit un "flash".

Si tu changes le cahier des charges tous les jours .....

Les entrées BP sont remplacées par des relais qui seront piloté via un automate.

Pourquoi alors cette usine à gaz .... si tu disposes d'un automate qui peut faire une grosse partie du job ?
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 02/04/2017, 11h22 #48  
J'avais pas vraiment de cahier des charges précis puisque je fais ça en loisir pour un club de modelisme.

Les automates qu'on utilise sont tous très différents, très basiques et ne permettent pas ce genre de fonction pas même le clignotement pour la plupart.
DAUDET78
DAUDET78 ★★★★★★★ 02/04/2017, 11h58 #49  
Posté par Partoutatis

pas même le clignotement pour la plupart.

Faut re-regarder la notice !
__________________
L'age n'est pas un handicap .... Encore faut-il arriver jusque là !
Partoutatis
Partoutatis ☆☆☆☆☆☆ 06/04/2017, 13h33 #50  
En tout cas merci pour votre aide, j'ai enfin réussis à faire tout un système en composants discrets, en me passant d'un µC.
Me reste à bien dimensionner mon NE555 pour l'oscillateur 0.5Hz, histoire de bien comprendre et calculer ma plage de temps état haut / état bas.
Répondre