ABCelectronique : portail d'information dans le domaine de l'électronique

Merci de ne pas poster des messages en relation avec le piratage.


    Forums de Abcelectronique > Electronique Analogique et Numérique
  » [Résolu] alimentation secourue
Identifiant Se souvenir de moi ?
Mot de passe
Répondre     Nouvelle discussion
[Résolu] alimentation secourue

 

gg25
gg25 ★★☆☆☆☆☆ 11/03/2017, 17h44 #1  
Bonjour à tous,

Je suis entrain de créer une carte pour commander un portail. Je suis entrain de réfléchir pour créer une alimentation secourue. Dans le synoptique que je joins, voilà comment je procède. J'ai un transformateur avec re-dressage et filtrage, sortie 12V/2,66A. Une partie de l'alimentation part dans un régulateur L200 pour charger une batterie, et la seconde partie dans des régulateurs de tension.

J'aimerais trouver une solution pour basculer sur le mode secours en cas de perte du secteur. J'avais pensé à un simple relais alimenté quand il y a le secteur, mais j'ai peur qu'avec le temps, en fonctionnant 24/24h pendant des mois, il se mette à coller.

Je suis preneur de toutes solutions :)

Bonne soirée à vous,

gg25
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  normal_secours.png
Affichages : 29
Taille :  26,0 Ko
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 11/03/2017, 17h57 #2  
tu te compliques inutilement la vie..

monte la batterie en tampon, tout simplement
__________________
L'avantage avec certains amis, c'est qu'on a pas besoin d'ennemis
gregelec
gregelec ★★★★★★ 11/03/2017, 17h57 #3  
Tu connais les diodes ? car ça marche pas mal pour ça ...
__________________
Dans le dictionnaire,réussite se trouve avant travail.Mais pas dans la vraie vie
DAUDET78
DAUDET78 ★★★★★★★ 11/03/2017, 19h30 #4  
Quelle batterie ?
au plomb ? 12V ?
Combien de Ah ?
__________________
je suis en vacances de 19 au 30 juin. Bon forum !
kabak_85
kabak_85 ★★★★★★ 11/03/2017, 20h15 #5  
Je dirais comme Daudet.
Faire une carte qui supportera une tension jusqu’à 15V, l'alimenter avec une batterie 12V au plomb qui sera elle même rechargée par un chargeur.

Lorsque le courant coupe, la batterie alimente le montage.
Lorsque le courant revient, le chargeur alimente le montage et recharge la batterie.

Si on prend une autonomie de 48h et un courant en sortie de chargeur qui est d'un dixième de la capacité de la batterie, la consommation de la carte ne représentera que 20% du courant nécessaire à la charge.
__________________
"Un probleme bien posé est a moitié résolu"
gg25
gg25 ★★☆☆☆☆☆ 12/03/2017, 00h09 #6  
Bonsoir à tous,

Il y avait une coquille dans mon schéma, je sors du transfo du 15V/2,66A.
La batterie est au plomb 12V avec une capacité de 2300mAh.
J'avais pensé aux diodes, mais il ne faut pas charger une batterie 12V avec une tension proche de 14V ? Et la frontière entre le 14 et 15V n'est pas très grande. Pas de risque de basculer sur la batterie au lieu du secteur ?

J'ai joins le schema que j'avais en tête avec les diodes.

N'hésitez pas à le critiquer.
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  schema.png
Affichages : 39
Taille :  159,4 Ko
DAUDET78
DAUDET78 ★★★★★★★ 12/03/2017, 07h52 #7  
Posté par gg25

je sors du transfo du 15V/2,66A.

C'est des Vefficace donc du 21V crête . donc suffisamment pour bien charger ta batterie

La batterie est au plomb 12V avec une capacité de 2300mAh.

Donc un courant de charge de 230mA max
__________________
je suis en vacances de 19 au 30 juin. Bon forum !
Thyratron
Thyratron ★★★★★☆☆ 12/03/2017, 08h05 #8  
Bonjour,
Une batterie au plomb possède l'avantage de supporter une charge permanente.
La brancher sur la tension avec une résistance de limitation de courant (puissance adaptée à batterie basse). Une diode en parallèle, connecte la batterie au montage quand le secteur disparaît.
Il n'y a pas de trou d'alimentation, pas besoin de se préoccuper d'un chargeur.
Le courant de charge doit permettre de recharger dans le cas de coupure le plus défavorable, qui dépend du lieu de résidence.
C'est simple et fonctionne à la perfection.
kabak_85
kabak_85 ★★★★★★ 12/03/2017, 09h25 #9  
Posté par gg25

J'avais pensé aux diodes, mais il ne faut pas charger une batterie 12V avec une tension proche de 14V ? Et la frontière entre le 14 et 15V n'est pas très grande.



Pour une charge "rapide" ou d'égalisation, la batterie au plomb se charge en 3 temps :
- Charge avec un courant limité jusqu'a 14,4V (tension et intensité dépendante de la technologie de la batterie donc voir sa fiche technique)
- Maintient à 14.4V pendant une durée limitée jusqu’à ce que l'intensité soient inférieure à une valeur dépendant de la capacité.
- Passage à une tension de maintient de 13.6V pour éviter de tuer la batterie par électrolyse.

Si tu n'as pas besoin de la recharger "rapidement", tu peux te contenter de la recharger en limitant le courant de charge à C/10 et d'utiliser une tension de 13.6V.


Ce dernier montage te permet de virer ton LM338 pour le 12V et de supprimer ton transistor de mise en charge.

Une dernière remarque pour le passage de 12V à 5V, il faudrait comparer la consommation de ton régulateur linéaire avec celle d'un régulateur à découpage. Selon la charge, il y aura moins de perte avec le régulateur à découpage.
__________________
"Un probleme bien posé est a moitié résolu"

Dernière modification par kabak_85 12/03/2017 à 09h31.
gg25
gg25 ★★☆☆☆☆☆ 12/03/2017, 11h43 #10  
Bonjour, donc si j'ai bien compris :
- Sois je l'alimente en parallèle du montage et j'utilise des diodes pour la bascule.
- Sois elle est incluse dans la chaîne d'alimentation. Mais j'avais lu que ce n'était pas top pour une batterie d'être chargé en permanence ? D'où mon "START-battery"

Le L200 est plus adapté à un vrai chargeur ?
Comment tout connecter ?
Transformateur -> re-dressage-> filtrage-> régulation 12V-> résistance limitation courant-> batterie-> montage ?

Dernière modification par gg25 12/03/2017 à 11h55.
kabak_85
kabak_85 ★★★★★★ 12/03/2017, 12h41 #11  
Tout dépend de la tolérance de tes équipements 12V. Si ton montage 12V tolère de monter jusqu’à 14/15V selon le mode de charge choisi, tu peux utiliser le montage suivant :
Transformateur -> redressement-> filtrage-> limitation courant/tension -> batterie-> (protection décharge profonde) -> montage.

Tu limites la complexité donc le risque de panne.
13.6V au lieu de 12, ça représente un écart de tension de 14%


Pour la durée de vie des batteries au plomb, c'est un domaine complexe. Le mieux est de regarder la fiche technique de la batterie.
Pour charger une batterie, il suffit une tension légèrement supérieur à la tension du premier couple oxydo-réducteur qui est grosso-modo de 2.14V/élément (soit 12.84V pour 6 éléments). Cette tension correspond d'ailleurs à la tension d'une batterie "chargé à 100%". C'est la valeur "inférieure" pour pouvoir charger une batterie.
Il y a un second couple d'oxydo-réduction qui se situe à environs 2.23V/élément (13.38V pour 6 éléments).

Au-dessus, on va accélérer la recharge mais on va aussi décomposer l'électrolyte plus vite que la batterie n'est capable de le recomposer et donc on va abimer la batterie ou la faire dégazer.

C'est pour cela que la charge à 14.4V est utilisé pour les usages "cyclique" car l'important est de charger la batterie rapidement et l'usure est un paramètre secondaire.
A contrario, pour une utilisation en sauvegarde, on préfère une tension plus faible car ce qui importe le plus, c'est la durée de vie de la batterie.
__________________
"Un probleme bien posé est a moitié résolu"
gg25
gg25 ★★☆☆☆☆☆ 12/03/2017, 12h53 #12  
Les composants qui ont besoin du 12v sont les relais, moteurs, flash, cellules photoélectrique​. Je vais regarder les datasheet, mais je ne suis pas sur que les cellules apprécies plus que 12V.

Avec quoi je règles la tension de charge de la batterie ? Un régulateur classique ou avec le L200 qui limite aussi le courant ?
kabak_85
kabak_85 ★★★★★★ 12/03/2017, 13h02 #13  
La partie charge doit être un régulateur de tension limité en courant donc le L200 tant que l'intensité de charge choisie n'est pas trop importante.
__________________
"Un probleme bien posé est a moitié résolu"
gg25
gg25 ★★☆☆☆☆☆ 12/03/2017, 14h59 #14  
Ce schéma conviendrait ?
Miniatures attachées
Cliquez sur l'image pour la voir en taille réelle

Nom :  alim_12V.png
Affichages : 30
Taille :  160,3 Ko
kabak_85
kabak_85 ★★★★★★ 12/03/2017, 15h23 #15  
Tu peux a mon avis supprimer la diode D2.

Dans le datasheet du L200, dans le schéma du chargeur, il y a une diode de protection contre les inversions de polarité entre la broche 2 et 3 ainsi qu'une résistance de limitation du court-circuit entre la broche 3 et la masse du montage.
__________________
"Un probleme bien posé est a moitié résolu"
dspix
dspix ★★★★★★★ 13/03/2017, 09h28 #16  
Salut,

Donc si je comprend bien, la carte d'automatisme n'est pas un truc du commerce, mais une fabrication perso ?

Dans ce cas, autant intégrer la fonction UPS à la carte de commande ! Tu rentres un 15V AC depuis un transfo qui va charger ta batterie et alimenter l’électronique. La commutation entre source d'alim se faisant donc avant les régulateurs.

Mais juste une question au passage : combien consomme le/les moteurs ?
__________________
A+
Damien
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 13/03/2017, 09h33 #17  
Posté par gg25

Ce schéma conviendrait ?



c'est ce que j'ai préconisé en #2
__________________
L'avantage avec certains amis, c'est qu'on a pas besoin d'ennemis
gg25
gg25 ★★☆☆☆☆☆ 13/03/2017, 18h04 #18  
Il faut que je vérifie mais de mémoire ils consomment 1A, donc 2A pour la puissance.
Et oui, je conçois la carte de A à Z.
Répondre