ABCelectronique : portail d'information dans le domaine de l'électronique

Merci de ne pas poster des messages en relation avec le piratage.


    Forums de Abcelectronique > Software / Péri-informatique
  » Carte mere et bios incoherent, probleme de flashage
Identifiant Se souvenir de moi ?
Mot de passe
Répondre     Nouvelle discussion
Carte mere et bios incoherent, probleme de flashage

 

PhilGooD
PhilGooD ☆☆☆☆☆☆ 23/08/2017, 09h19 #1  
Bonjour,
voila (mon/mes) problèmes, s'il vous plait, ayez un peu de patience c'est peu long:

Dans une déchetterie j'ai récupéré un ultraportable en panne ASUS S500CA-CJ039H sans disque dur, je l'ai branché sur un transfo et démarré, il arrive directement sous bios et la je vois que clavier ne fonctionne pas correctement ( defilement gauche sur la touche MAJ par exemple,surement la raison pour laquel il a été jeté ), par contre en branchant un clavier usb il fonctionne nickel, j'ai pu installer Windows sans problèmes.

J’achète un clavier sans être sure que le problème vient de la, un risque à 30€ mais ça vaut le coup si ça marche.

Résultat ça ne marche pas mieux, le problème est ailleurs, je pense à un problème de mappage clavier.
C'est la que ça devient incohérent, je regarde la version du bios, c'est la 208, je vais sur le site ASUS avec la bonne référence du pc et la, la version maximum proposé est la 204, je me dis que l'ancien proprio c'est planté de bios d’où peut être la panne clavier.
Je télécharge la bonne version mais au moment de reflasher le bios avec l'utilitaire ASUS fournit il ne veut en m'indiquant une erreur de version.

L'ancien bios est marqué S400CA 208 et le nouveau S500CA 204, comment a t'il pu flasher une mauvaise version.
J'ai acheté il y a quelques temps un programmateur d'EEPROM "EZP2013" avec une pince pour flasher sans dessouder.

Je repère la version de EEPROM "Windbond 25Q64", j'effectue une lecture du bios du et fais une sauvegarde puis

je flash la nouvelle version et la deja un petit souci, le nouveau bios pèse 6 Mo et la sauvegarde 8 Mo, au moment d’écrire le bios il me demande un indexe, je n'en met pas, l’écriture se passe bien mais au démarrage rien, aucune réaction, même la batterie ne charge plus, je tente de remettre le bios sauvegardé et même résultat.

Je me dis que j'ai peut être eu tord de me fier à l’étiquette sur le pc, je démonte la carte mère pour être sure de l'identifier et autre souci, sur le PCB il est écrit S400CA Rev 3.1 mais sur un autocollant S500CA.

Voila le souci, je vous demande de l'aide entre autre sur cette histoire d’index et de différence de taille de bios, j'ai pas trouvé de tuto pour le moment et aussi de m'aider à identifier avec certitude la carte mère, je joint les photos de mon matos.

http://zupimages.net/up/17/34/o7xl.jpg
http://zupimages.net/up/17/34/44w8.jpg
http://zupimages.net/up/17/34/qug4.jpg

Au cas ou les images ne passent pas:
http://zupimages.net/viewer.php?id=17/34/o7xl.jpg
http://zupimages.net/viewer.php?id=17/34/44w8.jpg
http://zupimages.net/viewer.php?id=17/34/qug4.jpg

Merci :)
siamois 29
siamois 29 ★★★★★☆☆ 23/08/2017, 10h48 #2  
bonjour,avant de flasher un bios vu que l'ordi fonctionnait à part ton clavier interne qui était soit hs ou autre.
déja il serait bon de savoir quel os il y avait d'origine normalement vu que tu avais acces au bios tu aurais le
modèle exacte du pc car dans certaines séries tu peux avoir plusieur modèles .
car ton modèle est celui la :http://www.laptopspirit.fr/126323/a...699e-promo.html .
en général quand je répare des pcs portables,je les démontent entièrement,nettoyage des ventilateurs et dissipateur avec changement pate thermique.
pour tester la carte mère je la pose sur une plaque de polycarbonate et la je raccorde les différent élements puis je la teste en branchant un écran externe ou soit le moniteur interne.
maintenant,j'ai bien peur que tu est endommager ta carte mère et en général ta carte mère avait un problème soit le controleur clavier hs.
en général quand j'ai un problème de clavier soit c'est connectique ,j'essai en changeant le clavier en premier lieu mais en aucun cas de flasher le bios avant d'avoir fait tout les test nécessaires.
d'ailleur si tu as un bios défectueux ta carte mère ne fonctionnera pas du tout ou alors tu auras des problèmes.
mais attend d'autres avis,plusieurs te donneront de meilleurs réponses.
la bientot je vais faire un banc te test pour tester les cartes mères de pcs portables .
a+.
dspix
dspix ★★★★★★★ 23/08/2017, 12h50 #3  
Salut,

Pour la taille de ton bios, ce n'est pas anormale. La lecture avec la sonde lit toute l'eprom, soit 8M dans ton cas. En effet, le prog de lecture ne sait pas ce que contient l'eeprom.
Par contre, le flash du bios ne contient que les données utiles.

Un test a faire : reprogramme l'eprom avec la sauvegarde que tu as faite. Puis refait une sauvegarde et compare la avec le contenu de la 1ere sauvegarde. Si c'est identique c'est que la réécriture avec le bios d'origine s'est bien passé et que tu as cassé autre chose en flashant le mauvais firmware. Ton PC va pouvoir retourner d'ou il vient...
__________________
A+
Damien
bonnetgeor
bonnetgeor ★★★★★★ 23/08/2017, 20h19 #4  
Posté par PhilGooD

l'ancien bios est marqué S400CA 208 et le nouveau S500CA 204, comment a t'il pu flasher une mauvaise version.


Et bonsoir...
En effet, l'ancien proprio s'est planté de bios : c'est ballot...
Comment as-t'il fait ? Et bé... il l'a fait et ça, ce n'est pas normal car l'ordi aurait dû refuser cette mise à jour, quelque soit la méthode de flashage...
__________________
La seule chose que l'on peut prévoir dans la vie, c'est... son imprévisibilité !
bonnetgeor
bonnetgeor ★★★★★★ 23/08/2017, 22h50 #5  
Re...
Normalement, il est possible de downgrader un bios Asus à une version antérieure :
https://www.forum-des-portables-asu...os-de-son-asus/

Évidemment, vu que dans le cas présent, le bios n'est pas celui de la machine, ça complique les choses...
Peut-être qu'en downgradant le bios actuel S400CA208 vers la version la plus ancienne possible (la S400CA203 d'après le site Asus), il serait possible ensuite d'installer ce S500CA204 ?
__________________
La seule chose que l'on peut prévoir dans la vie, c'est... son imprévisibilité !
dspix
dspix ★★★★★★★ 24/08/2017, 08h40 #6  
Perso j'en suis pas si sure !

Si le PC démarrait, c'était le bon BIOS. Se méfier entre la ref inscrite sur le pc et les composants réellement implantés.

Il n'est pas rare de trouver des fabrications spéciales d'une certaine référence de machine avec d'autres composants. Cas typique, les prix promo catalogue de GSB... On y trouve une machine bradé, mais si le début de la ref correspond bien a un type de machine identifié, la fin de la ref est un truc unique qui n'est vendu que pas l'enseigne en question... Et quand on compare la configuration fournie, elle diffère légèrement de la config type présenté par le fabricant. Au final on croit faire une bonne affaire car la même machine (même apparence physique) est vendu plus cher partout ailleurs. Mais en fait non, la config hardware est différente avec parfois des surprises du style on mets la carte mère d'un modèle plus vieux ou un chipset plus vieux.
__________________
A+
Damien
siamois 29
siamois 29 ★★★★★☆☆ 24/08/2017, 09h59 #7  
Posté par dspix

Perso j'en suis pas si sure !

Si le PC démarrait, c'était le bon BIOS. Se méfier entre la ref inscrite sur le pc et les composants réellement implantés.

Il n'est pas rare de trouver des fabrications spéciales d'une certaine référence de machine avec d'autres composants. Cas typique, les prix promo catalogue de GSB... On y trouve une machine bradé, mais si le début de la ref correspond bien a un type de machine identifié, la fin de la ref est un truc unique qui n'est vendu que pas l'enseigne en question... Et quand on compare la configuration fournie, elle diffère légèrement de la config type présenté par le fabricant. Au final on croit faire une bonne affaire car la même machine (même apparence physique) est vendu plus cher partout ailleurs. Mais en fait non, la config hardware est différente avec parfois des surprises du style on mets la carte mère d'un modèle plus vieux ou un chipset plus vieux.



salut,
c'est souvent le cas tu as la meme carte mais avec une config differente du pc qui as plusieurs variantes soit au niveau chipset,pro,ou carte graphique.
le plus drole souvent quand tu regarde la reférence du pc si tu vas faire un
tour dans le bios,il t'indiquera un autre modèle que la reference inscrite sur
le pc.
a+.
bonnetgeor
bonnetgeor ★★★★★★ 24/08/2017, 12h34 #8  
Posté par dspix

Si le PC démarrait, c'était le bon BIOS.


Et bonjour...
Désolé, je ne suis pas d'accord et maintiens que ce n'est pas le bon bios.
Si tu vas sur le site HP, il y a un bios pour le S400CA et un autre pour le S500CA, ce n'est pas pour rien !
Certes, les deux bécanes sont très similaires et ont presque les mêmes CM -mais avec un chipset différent- mais le premier a un I3, un écran de 14", un clavier sans pavé numérique, etc. alors que le second a un I5, un écran de 15,6", un clavier avec pavé numérique, etc.
Bref, il y a assez de similitude pour expliquer le démarrage du S500 avec le bios du S400 et assez de différences pour justifier deux bios différents et expliquer la réaction fantasque du clavier du S500CA et sans doute d'autres choses...
__________________
La seule chose que l'on peut prévoir dans la vie, c'est... son imprévisibilité !
dspix
dspix ★★★★★★★ 24/08/2017, 13h29 #9  
Posté par bonnetgeor

Désolé, je ne suis pas d'accord et maintiens que ce n'est pas le bon bios.


Moi non plus suis pas d'accord... :P

A la relecture du 1er message, tu peux notamment lire que si sur le PC il y'a bien la ref S500CA d'inscrite, sur la CM il y a marqué S400CA par dessus l'autocollant S500CA.

Ces 2 machines sont peut être suffisamment proche pour avoir une carte mère commune et seulement du microcode différent sur une machine ou l'autre.
Un opération commerciale visant a écouler un stock de CM S500CA reconfigurer en S400CA, un reconditionnement de machine... un remplacement en SAV, un bricolage... Bref, on ne connaît pas l'historique de la machine... Mais perso, j'ai plus confiance au marquage qui figure sur la CM que sur le PC...

En tout cas on peut très bien imaginé que la CM d'origine est tombée en panne. Que le proprio a trouvé une S500 (reconditionnée en S400) sur ebay, la mise dans la machine. Le clavier n'étant pas le même entre le 400 et le 500 génère donc un problème de mapping. Décidant de jeter l'éponge il apporte l'ordi en D3E.
__________________
A+
Damien

Dernière modification par dspix 24/08/2017 à 13h34.
bonnetgeor
bonnetgeor ★★★★★★ 24/08/2017, 20h46 #10  
Et bonsoir
Posté par dspix

Moi non plus suis pas d'accord... :P


C'est absolument ton droit de rester dans l'erreur... :p :p

A la relecture du 1er message, tu peux notamment lire que si sur le PC il y'a bien la ref S500CA d'inscrite, sur la CM il y a marqué S400CA par dessus l'autocollant S500CA.


Bin non, pas du tout ; c'est l'inverse ! (d'après la première photo)
Il y a "S400CA rev 3.1" sérigraphié sur le PCB de la MB et "S500CA" sur une étiquette...
Donc, cette carte-mère est une S400CA de conception, pas une S500CA...

Ces 2 machines sont peut être suffisamment proche pour avoir une carte mère commune et seulement du microcode différent sur une machine ou l'autre.


Là, je suis plus divergeant quant aux cartes-mères qui, bien que basées sur le même PCB, doivent obligatoirement différer par certains composants implantés vu les caractéristiques différentes des deux ordis.
D'où la nouvelle référence de la carte-mère et un nouveau bios spécifique...

Une opération commerciale visant a écouler un stock de CM S500CA reconfigurer en S400CA, un reconditionnement de machine... un remplacement en SAV, un bricolage... Bref, on ne connaît pas l'historique de la machine... Mais perso, j'ai plus confiance au marquage qui figure sur la CM que sur le PC...


Je réitère pour info que cette carte-mère est une S400CA de conception, pas une S500CA...
Quant à moi, je me base toujours sur la référence complète d'un ordinateur de "marque" pour trouver son bios sur leur site et à rien d'autre ! (*)

En tout cas on peut très bien imaginé que la CM d'origine est tombée en panne. Que le proprio a trouvé une S500 (reconditionnée en S400) sur ebay, la mise dans la machine. Le clavier n'étant pas le même entre le 400 et le 500 génère donc un problème de mapping. Décidant de jeter l'éponge il apporte l'ordi en D3E.


Hormis ta confusion avec les références, cette hypothèse est parfaitement concevable...
... parmi moult autres possibles...

(*) : pour illustrer mes propos, je vais prendre l'exemple des marques d'assembleurs renommés (HP/Compaq, Acer/PB/feux emachines, etc.).
Souvent, ces assembleurs vont piocher dans les catalogues de fabricants de carte-mères pour choisir la référence répondant à un futur modèle
Et très souvent, ils demandent au fabricant de la carte-mère sélectionnée d'y apporter quelques adaptations, souvent des simplifications d'ailleurs...
Ces cartes-mères "adaptées" portent de fait plusieurs références : celle de la carte d'origine sérigraphiée, celle de la carte si "adaptée" sur une étiquette collée sur celle d'origine et/ou celle de l'assembleur.
Évidemment, les bios des cartes d'origine (bios disponibles chez le fabricant) et des "adaptées" (bios disponibles chez l'assembleur) ne sont pas les mêmes et ne peuvent être intervertis sous peine de créer des problèmes irréversibles, chose souvent précisé par les assembleurs, d'ailleurs.
J'ai eu essayé de passer outre "pour voir" mais ils avaient raison, CM inutilisable ! :(
Alors depuis, j'applique la procédure normale de mise à jour des bios sans jouer aux apprentis sorciers sur ce sujet...
__________________
La seule chose que l'on peut prévoir dans la vie, c'est... son imprévisibilité !
dspix
dspix ★★★★★★★ 24/08/2017, 22h52 #11  
Ouin confusion... mais ce que je voulais dire : le bios initialement implanté correspond bien a la ref de la carte mère sérigraphié sur le pcb ! L'étiquette collé avec s500 peut être une erreur de reconditionnement....

En tout cas, depuis relativement longtemps, les outils de flashage vérifient que le nouveaux bios est bien compatible et ce même pour une même carte mère mais de révision différente... Il n'est donc pas possible de mettre le bios d'un rev 1.3 sur une rev 1.2 et vice versa en utilisant l'outils mis a dispo par le fabricant de la machine.
__________________
A+
Damien
bonnetgeor
bonnetgeor ★★★★★★ 25/08/2017, 09h18 #12  
Et bonjour...
Posté par dspix

Ouin confusion... mais ce que je voulais dire : le bios initialement implanté correspond bien a la ref de la carte mère sérigraphié sur le pcb ! L'étiquette collé avec s500 peut être une erreur de reconditionnement.....


Vu le fabricant et les équipements et prix de ces ordis, je ne crois pas que Asus est fait une telle erreur...
Mais, comme tu l'as dit, on ne connaît pas le passé de cette bécane en panne issue des DEEE...

En tout cas, depuis relativement longtemps, les outils de flashage vérifient que le nouveaux bios est bien compatible et ce même pour une même carte mère mais de révision différente... Il n'est donc pas possible de mettre le bios d'un rev 1.3 sur une rev 1.2 et vice versa en utilisant l'outils mis a dispo par le fabricant de la machine.


En effet, l'outil de flashage vérifie normalement la compatibilité du bios avec la carte-mère mais, de constat vécu, une rev différente n'implique pas toujours l'usage d'un bios différent...
Bref, en ce qui me concerne, je n'ai pas d'autre choix que de faire confiance au fabricant et à son outil de flashage...
...et je n'ai jamais eu de problème jusqu'à maintenant, même après moult flashages de moult cartes...
__________________
La seule chose que l'on peut prévoir dans la vie, c'est... son imprévisibilité !
Répondre