ABCelectronique : portail d'information dans le domaine de l'électronique

Merci de ne pas poster des messages en relation avec le piratage.


    Forums de Abcelectronique > Electronique Analogique et Numérique
  » Pourquoi je ne mesure pas la même tension avec mon voltmètre et mon capteur ?
Identifiant Se souvenir de moi ?
Mot de passe
Répondre     Nouvelle discussion
Pourquoi je ne mesure pas la même tension avec mon voltmètre et mon capteur ?

 

jvl
jvl ☆☆☆☆☆☆☆ 11/05/2017, 10h57 #1  
Bonjour,

Je précise que je n'y connais rien en électronique.

J'ai une sonde passive qui sort une tension entre 0 et 47mV
Si je mesure la tension aux bornes de cette sonde qui est dans un état stable je mesure : 45mV

Je raccorde cette sonde à un capteur qui a une entrée 0-10V avec comme indiqué dans la documentation : the input is internally pulled down and the input impedance is 7.4 ohm
Je mesure la tension aux bornes du capteurs et j'ai 23mV

1 ) Quelle est la formule pour passer de 45 à 23mV, je suppose que cela a un rapport avec la résistance pull-down ?

2) Si c'est le rapport de tension entre la sonde à l'état 1 (S1) et la sonde ) l'état 2 (S2) qui m'intéresse.
Est-ce que j'aurai le même rapport si je fais les mesures tantôt directement à la sonde, tantôt au niveau du capteur ?

Est-ce que S1/S2=S'1/S'2 ?

où S = mesure tension directement sur la sonde
S' = mesure tension sur le capteur avec résistance pull-down

Merci pour votre aide,

JV
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 11/05/2017, 11h34 #2  
avec une impédance d'entré de 7,4 Ω (ce qui me parait fort peu) , il est évident que la sonde s'effondre.

pour le calcul, il faut connaitre l'impédance de la sonde.

D'AUTRE PART,

quid de la précision d'un capteurs 10 volts mesurant une tension de 0,043 V :(
jvl
jvl ☆☆☆☆☆☆☆ 11/05/2017, 11h45 #3  
euh pardon, c'est 7,4 kohm

je connais pas l'impédance de la sonde, je vais voir si je peux demander au constructeur

effectivement pour la précision du 0-10V, je n'arrive pas a voir l'info du constructeur mais je sais que c'est codé sur 16 bits.

Concernant la réponse à la question 2) avez-vous une idée ?

Merci
pym
pym ★★★★★★★ 11/05/2017, 11h46 #4  
7.4Ohms est très improbable!!
A+
__________________
Je préfère les laides car elles sont plus lumineuses que les ampoulées
guy92
guy92 ★★★★★★ 11/05/2017, 11h55 #5  
Posté par jvl

euh pardon, c'est 7,4 kohm

je connais pas l'impédance de la sonde, je vais voir si je peux demander au constructeur

effectivement pour la précision du 0-10V, je n'arrive pas a voir l'info du constructeur mais je sais que c'est codé sur 16 bits.

Concernant la réponse à la question 2) avez-vous une idée ?

Merci




Ben, tu as toutes les données...

Codé sur 16 bits cela donne quoi comme pas d'échantillonnage?
Moi j'ai la réponse et je suis pas le seul
Pour t'aider il suffit de diviser 10V pas le nombre de valeurs possibles avec 16bits.

C'est un devoir à rendre?

Dans la doc du convertisseur chercher la précision de mesure et l'erreur d'offset.
__________________
More the knowledge lesser the Ego, lesser the knowledge, more the Ego
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 11/05/2017, 11h55 #6  
pour la question 2) c'est le calcul d'un diviseur de tension :

cours de physique de première S

toutefois , cette mesure exploitant un CAN en tout début de gamme sera foireuse...
les mathématiques sont formelles !

il faut un traitement analogique en amont

Dernière modification par AUDIOVALVE 11/05/2017 à 12h23.
jvl
jvl ☆☆☆☆☆☆☆ 11/05/2017, 12h18 #7  
non, ce n'est pas un devoir à rendre et ca date de 25ans la 1ere S pour moi

pas cool mais je vais trouver...
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 11/05/2017, 12h24 #8  
si tu nous expliquais le contexte , on pourrait mieux cibler l'aide ...

car là , c'est du n'importe quoi
guy92
guy92 ★★★★★★ 11/05/2017, 13h48 #9  
Pas cool? et pourquoi?

Je te donne la démarche à suivre, te donner la réponse brute ne sert à rien si tu ne comprends pas comment cela marche.

Voila quelques questions,
Plutôt que de dire "pas cool" essaye de nous dire si tu comprends la question et si tu ne trouve pas la réponse je te la donnerais.

Codé sur 16 bits cela donne quoi comme pas d'échantillonnage?
Comprends tu ce qu'est un codeur 16 bits et la diference par rapport à un codeur 15 bits?
Quel est le nombre de valeurs possibles différentes avec 16bits?

SI tu divise la plage de mesure 0 a 10V par le nombre de valeurs cela te donnera le pas de mesure.


Dans la doc du convertisseur peux tu chercher la précision de mesure et l'erreur d'offset?
Et si tu peux mets nous la référence et la doc de ce convertisseur.
__________________
More the knowledge lesser the Ego, lesser the knowledge, more the Ego
Thyratron
Thyratron ★★★★★☆☆ 11/05/2017, 16h29 #10  
Pour confirmer le désaccord mesure avec la valeur renvoyée, une mesure à vide comparée avec branchée a-telle état faite?
Utiliser un signal faible avec un appareil capable de traiter jusqu'à 200 fois plus n'est pas très heureux.
Introduire un ampli (précis et stable) avec un gain adapté de manière à renvoyer un signal dans le milieu de la gamme, 5v serait judicieux.
Inconvénient, un étalonnage sera nécessaire, valeur lue = K * Ve.
Acetronics
Acetronics ★★★★★★ 11/05/2017, 18h35 #11  

je connais pas l'impédance de la sonde, je vais voir si je peux demander au constructeur



avec tes 2 mesures de tension, tu peux la calculer ...

dans le premier cas, elle n'est chargée que par +/- 1Mohm ( multimètre supposé pas trop pourri ...)
dans le second elle est chargée par 1Mohm en // avec tes 7.4 kOhms.

y'a plus qu'à sortir la calculette ...

Alain
__________________
Si ta question contient le mot " Problème " ...
la réponse est très très très probablement " lis donc ton manuel ou ta datasheet !!! "
AUDIOVALVE
AUDIOVALVE ★★★★★★★ 11/05/2017, 18h51 #12  
un lien sur la sonde ?

comment est elle alimentée ?
Répondre