ABCelectronique : portail d'information dans le domaine de l'électronique
Home » Diverses rubriques » Archive forum sujets+corp
 
     
   Parasites S-Vidéo  
Bonjour,

J'ai un PC avec la carte vidéo ATI Radeon 9800 Pro.
Je viens d'acheter un cable s-video à priori de bonne qualité (belkin gold series) de 10m.

Lorsque je relie mon PC à la télé via ce cable, l'image apparait correctement mais il y a 2 bandes (composées de lignes claires en diagonales) sur la télé qui en général descendent.
J'espère que l'explication est claire. Je pense que ces 2 bandes sont des parasites.

Suite à ce problème, j'ai fait une multitude de tests et je m'arrache les cheveux.

Exemple de tests réalisés :

1.
Ordinateur dans le bureau
TV dans le salon
Cable de 10m s-vidéo

----> Les parasites apparaissent

2.
Ordinateur dans le salon à côté de la télé
Cable de 10 m s-vidéo

---> Les parasites disparaissent

3.
Ordinateur dans le salon à côté de la télé
Rallonge électrique entre prise murale et UC (juste pour test)
Cable de 10 m s-vidéo

---> Les parasites réapparaissent


4.
Ordinateur dans le salon à côté de la télé
Rallonge électrique entre prise murale et UC (juste pour test)
Cable de s-vidéo d'un mètre fourni avec la carte vidéo

--> Pas de parasite

5.
A l'autre bout du salon, j'ai 2 autres prise murales.
Une semble être avec terre et l'autre non (je ne m'y connais pas en électricité).
Pour cette expérience l'UC n'est pas déplacé, ni le cable s-vidéo. Seul le cable d'alim de l'UC change de prise murale.

TV toujours au même endroit.
Cable de 10m s-vidéo
UC relié directement sur la prise murale avec terre

---> Les parasites apparaissent

TV toujours au même endroit.
Cable de 10m s-vidéo
UC relié directement sur la prise murale sans terre

---> Les parasites disparaissent

A titre d'information, j'ai déjà fait changé le cable s-vidéo de 10m mais ca n'a rien changé.

Y a t'il quelqu'un qui comprend quelques choses à mon problème ?
Et surtout, y a t'il une solution pour faire fonctionner l'ordinateur dans le bureau, la télé dans le salon et la cable s-vidéo de 10m entre les 2 ?

Faut il changer de cable ?
Est ce désespérer ?
Y a t'il des choses à faire sur les prises murales ?

Merci beaucoup pour toute l'aide que vous pourrez m'apporter.

Arnaud

Numéro de l'article: 96601   |  De: arnaud   |  Date: 2004-05-11 21:51:36
   RE: Parasites S-Vidéo
Ta distribution électrique dans la maison est-elle en monophasé ou triphasé?

A+

Numéro de l'article: 96805   |  De: pym   |  Date: 2004-05-12 12:55:09
   RE: Parasites S-Vidéo
Bonsoir

As-tu essayé en enlevant la connexion vers la télédistribution??

Si ça fonctionne en l'enlevant, place 2 condensateur de 0.1µF entre les masses et les ames de ton coax vers la TVD.

A bientôt
Tiens nous au courant

Numéro de l'article: 97013   |  De: EPERVIER   |  Date: 2004-05-12 22:27:56
   RE: Parasites S-Vidéo
Bonjour,

comment puis je savoir si la distribution électrique est monophasé ou triphasé ?

Cordialement,

Arnaud Coulon

Numéro de l'article: 104041   |  De: coulon   |  Date: 2004-06-02 09:46:26

   Après les fonds d'écrans, les screensavers...  
Salut à tous,

Je vous avais fait découvrir il y a qq temps un site très sympa de fonds d'écran sur
http://gallery-wallpaper.mine.nu
et bien, le webmaster a eu la bonne idée de les proposer en screensavers sur
http://gallery-screensaver.mine.nu
bref que du bon !!

++
ptitso

Numéro de l'article: 96610   |  De: Ptitso   |  Date: 2004-05-11 22:09:24
   RE: Après les fonds d'écrans, les screensavers...
ça viens faire quoi dans un forum d'électronique ????

Numéro de l'article: 96698   |  De: Cédric   |  Date: 2004-05-12 10:06:04

   Interrupteur  
Salut a tous
Je voulais savoir si quelqu'un connaissais un montage (a faire soit meme) pour faire un interrupteur que l'on peut commander a distance (environ 5m) soit par le bruit ou par IR ou si vous avez d'autres solution.
Sa serai juste pour allumer une lampe faible consommation.
Merci


Numéro de l'article: 96613   |  De: guy   |  Date: 2004-05-11 22:13:40
   RE: Interrupteur
Je tedéconseille par le bruit, le chien du voisin allumerait la lampe.
Par IR, des montages simples de télécommandes doivent se trouver dans la rubrique ... montages !

Numéro de l'article: 96634   |  De: dajp   |  Date: 2004-05-11 23:23:18
   RE: Interrupteur
nan g un montage que jai realisé sur Orcad il es mise en oeuvre avc un Buzzer piezo electrik en tant ke micro...on dit quil a la particularité de bien reagir o clapement de mains

euh je l es pa encor tester mé bon....si ta Oracd je tenvoi le schema et tu le testera pour moi

Numéro de l'article: 96645   |  De: Bandit972   |  Date: 2004-05-12 00:58:02
   RE: Interrupteur
pour quelle application exactement ? :)

Numéro de l'article: 96719   |  De: Manu   |  Date: 2004-05-12 10:39:11

   voyant de charge  
Bonjour,
voila je vient de retaper une meharie mais j'ai un petit souci avec mon voyant de charge batterie.
sur ce modele il etait prevu de monter un voltmetre, mais sur mon nouveau tableau de bord j'ai un voyant, quelqu'un aurait il un petit montage a me proposer afin que le voyant s'allume si la tension de charge est inferieur à environ 13.5 v.
merci d'avance

Numéro de l'article: 96632   |  De: tomy   |  Date: 2004-05-11 23:04:19
   RE: voyant de charge
Le voyant est généralement une ampoule de 1W branchée entre le + alternateur et le + batterie (allumée si l'alternateur ne fourni rien)

Numéro de l'article: 96633   |  De: dajp   |  Date: 2004-05-11 23:19:19
   RE: voyant de charge
Bonjour, voici un schéma qui s’articule autour d’un comparateur :

Ce montage ne nécessite qu'un seul réglage, celui de du potentiomètre P.
Mettre la tension VCC à 13 V et faire varier la valeur du potentiomètre jusqu'à ce que la LED rouge s'allume.
Une fois ce réglage effectué, faire varier la tension VCC pour vérifier le bon réglage.
Lorsque la tension d'alimentation est au dessus de 13V, la LED rouge doit s'éteindre et inversement lorsque la tension VCC est en dessous de 13V.

Cliquez ici pour ouvrir l'image


Numéro de l'article: 96656   |  De: luc   |  Date: 2004-05-12 08:12:41
   RE: voyant de charge
je te remerci de ton attention Luc mais le lien photo ne marche pas
Merci

Numéro de l'article: 96990   |  De: tomy   |  Date: 2004-05-12 21:13:57

   Ref motorola.  
salut à tous,
Quelqu'un pourrait-il m'expliquer de que siginifie les ref E/P
I/P
apres la reference d'un PIC comme le 18F452 E/P
18F452 I/P
Merci d'avance...

Hervé.

Numéro de l'article: 96637   |  De: cielether   |  Date: 2004-05-12 00:00:01

   cours electro. marine  
bonjour,

je recherche des cours electronique marine dispensé à l'AFPA de Rochefort.
si vous possedez des cours similaires, je suis preneur.
merci d'avance

Numéro de l'article: 96639   |  De: xavier   |  Date: 2004-05-12 00:04:47

   mode d'emploi VHS-C. UN telefunken 7900M.  
bonjour,
Je viens d'acquérir un magnétoscope VHS-C. UN telefunken 7900M.
Le seul PB il me manque la notice. est-ce que qqun sait ou on peut la récupérer.

Sinon y a-t-il qqun qui connait ces deux symbole? (ça pourrait déjà m'aider.


merci d'avance
Cliquez ici pour ouvrir l'image


Numéro de l'article: 96640   |  De: flnyarla   |  Date: 2004-05-12 00:08:30

   problème d'alim  
J'ai 2 filtres à alimenter avec un seul convertisseur DC/DC traco qui délivre un +12v et -12v.
IL s'agit d'un MF10 qui doit être alimenter entre 9v et 14v (vsupp) et d'un MAX275 qui doit être alimenter entre +/- 2,37 v en minimum et +/- 5,5v maximum (v+-v-).

J'ai trouvé une solution mais je ne sais pas si cela est possible:

Je met 3 résistances en serie, et de même valeur pour faire un diviseur de tension sur le 12v du convertisseur DCDC. Idem sur la borne -12V du convertisseur.
Le potentiel de la derniere resistance est donc de -4v ( pour -12v), et +4v (du côté du +12v).
J'alimente mon max275 avec le +4v et -4V.
Mon MF10 est directement branché entre +12V du convertisseur et la masse.

Si quelqu'un peut me confirmer par mail, ou me conseiller un site ce serait sympa.

Je recherche aussi de la doc sur les diodes zener (avec une alim double) pour faire une référence pour aop.

merci d'avance



Numéro de l'article: 96643   |  De: MT   |  Date: 2004-05-12 00:33:01
   RE: problème d'alim
Bonjour MT,

Je vous transmets l'adresse de mon site à laquelle que vous pouvez calculer vos résistances de vous-même, etc...

Site Educatif : http://perso.wanadoo.fr/daniel.robert9/Liaisons_serie_Liaisons_parallele.html

http://perso.wanadoo.fr/daniel.robert9

Cordialement et @ +

Daniel


Numéro de l'article: 96649   |  De: Daniel   |  Date: 2004-05-12 02:23:38
   RE: problème d'alim
Il faudrait connaitre le courant absorbé par le MAX 275 pour proposer une solution qui ne sera surement pas constituée que de résistances...

A+

Numéro de l'article: 96663   |  De: pym   |  Date: 2004-05-12 09:02:37
   RE: problème d'alim
tu veux réaliser un diviseur de tension, le problème c'est qu'il faut que le courant consommé par ta charge (Max 275) soit négligeable devant le courant circulant dans ton pont diviseur (exemple <10%); tu dois donc calculer la résistance globale de ton diviseur en fonction de ce critère.
Il faut connaitre le courant consommé par le MAX275 (et est il à peu prés constant: sinon ses tensions d'alim risquent de fluctuer)

Numéro de l'article: 96689   |  De: BOBO59   |  Date: 2004-05-12 09:50:05

   Questions sur relais et inversion de polarité  
Bonjour tout le monde, je n'ai qu'un e connaissance de base en electronique mais je m'efforce d'Approfondire mes connaissances par la pratique.

Mon problème Est que sur mon auto j'ai un system d'alarme et il a l'option pour verrouiller/déverrouiller les portières. J'ai utilisé 2 Relais Standard, un qui est pour le déverrouillage et l'autre pour le verrouillage, en utilisant les pin #87 pour le positif, les pin #30 recoivent le signale du sytem d'alarm et les #87a sont connecté au barrures électrique.

Avec ses branchements, je recoit une impulsion de +12v de la par d'un relais pour déverrouiller et de l'autre lorsque je verrouille. Mon problème est que les barrures que j'ai fonctionnent par inversion de polarité, pour être en mesure de compléter mon branchement il faudrait que un relais sont connecté inversement à l'autre, ce que je ne peux pas faire car selon ma logique ça créerait un court-circuit.

Merci beaucoup de votre aide
J'Ai lue quelques message et votre forum est très intérescant, félicitation!!


Numéro de l'article: 96648   |  De: Alienpit   |  Date: 2004-05-12 01:42:02
   RE: Questions sur relais et inversion de polarité
qu'entends tu par relai "standard" ? S'ils n'ont qu'un seul contact travail ca va être difficile, il te faut des relais avec 2 contacts travail ( 1 pour le +, 1 pour le - )

Numéro de l'article: 96775   |  De: dajp   |  Date: 2004-05-12 11:56:46
   RE: Questions sur relais et inversion de polarité
Salut,

Je pense pourvoir t'aider mais ton explication n'est pas très, euh, comment dire, claire ?

Alors essaye de faire un petit schéma si tu peux...


désolé
A+



Numéro de l'article: 96781   |  De: TOF   |  Date: 2004-05-12 12:11:55
   RE: Questions sur relais et inversion de polarité
finnalement j'ai trouvé la solution, voici le shema, mais le 87 et 87a sont inversé dessus, petite erreur que j'ai fait en dessinant
Cliquez ici pour ouvrir l'image


Numéro de l'article: 96973   |  De: Alienpit   |  Date: 2004-05-12 19:38:52

   Ampli à 13.56 MHz  
Slt,

Je cherche à amplifier des signaux modulés sur une porteuse à 13.56 MHz (amplitude d'environ 2V crête crête à la base). Est ce que c'est possible en gardant une bonne qualité de signal et si oui, connaitriez vous des composants pour faire ca. Merci d'avance.

@+.
Ciao. Fabe

Numéro de l'article: 96650   |  De: fabe   |  Date: 2004-05-12 04:28:14
   RE: Ampli à 13.56 MHz
Salut

A cette fréquence, un simple transistor type 2N3553, 2N3866 ou 2N4427 doit fait l'affaire. Il serait judicieux de préciser le gain souhaité et la tension d'alim disponible.

A+

Numéro de l'article: 96673   |  De: SuperPapum   |  Date: 2004-05-12 09:28:57
   RE: Ampli à 13.56 MHz
slt,

merci de ta réponse.

pour le gain je ne sais pas trop, le plus possible avec l'alim de 5V disponible!

Merci. @+.
Fabe

Numéro de l'article: 96825   |  De: fabe   |  Date: 2004-05-12 14:28:10
   RE: Ampli à 13.56 MHz
Salut,
Ou alors un JFET 2N3819, qui fonctionne à merveille à cette fréquence
See you


Numéro de l'article: 96853   |  De: Patman   |  Date: 2004-05-12 15:10:53
   RE: Ampli à 13.56 MHz
Salut

.... tout dépend s'il faut traiter de la puissance ou non.

A+

Numéro de l'article: 96860   |  De: SuperPapum   |  Date: 2004-05-12 15:16:39
   RE: Ampli à 13.56 MHz
Merci pour vos réponses, je vais voir ce que je peux faire!

@+
Ciao. Fabe

Numéro de l'article: 97737   |  De: fabe   |  Date: 2004-05-14 15:09:59

   contacteur a distance  
bonjour,je travaille dans le milleu sous-marin et je recherche un transmeteur, asses puissant pour fonctionner sous l eau.ce transmeteur aurais pour but ,le declanchement a distance (50metres voir plus) d un moteur electrique (type fermeture de voiture,on,off)ou d un systeme pyrotechnique (declenchement d une spaklette de co2)

merci

Numéro de l'article: 96652   |  De: vince   |  Date: 2004-05-12 06:30:17
   RE: contacteur a distance
Le milieu sous marin est hostile aux hautes fréquences, oriente tes recherches vers les transmissions grandes ondes ( 150-300 khz)

Numéro de l'article: 96771   |  De: dajp   |  Date: 2004-05-12 11:49:55
   RE: contacteur a distance
merci a daip
dans quelle aplication trouve ton des transmision grandes ondes(contacteur )ou et il possible d en bricoler une ?(en prendre une normale type voiture ou autre et lui changer la frequence d emision
ps je suis pas du tout electronicien ,mais plongeur sousmarin et j en aurais besoin pour un bon bricolage!
merci

Numéro de l'article: 97045   |  De: vince   |  Date: 2004-05-13 01:02:06

   Recherche IC HT8950  
Hello je recherche un IC HT8950 ( voice modulator).
Mais je ne trouve pas de fournisseur pour pouvoir le commander !!!!!
si quelqu'un trouve où je pourais le commander, cela serait sympa de me renseigner.
Merci d'avance.

Numéro de l'article: 96660   |  De: noah_106   |  Date: 2004-05-12 08:56:16

   ampli passe bande  
Hello,

Etudiant en IUT GEII, je suis actuellement en stage et j'ai comme projet de réaliser un recepteur HF.
Dans ce projet, j'ai un ampli passe bande à faire et j'ai opté pour un RLC. je voulais savoir si il exite un meilleur type de filtre, et si non, le type de bobine à utiliser (torrique,blindé, avec férrite...)

vouli voula... merci d'avance et bonne journée
@pluche

Numéro de l'article: 96665   |  De: Kyub!   |  Date: 2004-05-12 09:08:11
   RE: ampli passe bande
y a des schemas a ampli op et des filtres numeriques.Tout depend du type de signal que tu filtres et de la frequence de coupure

Numéro de l'article: 96670   |  De: jpascal   |  Date: 2004-05-12 09:25:06
   RE: ampli passe bande
je filtre un signal sinusoidal de 70MHz ( enfin sinusoidal apres le filtre).. et les frequence de coupures sont 69 et 71MHz

Numéro de l'article: 96697   |  De: Kyub!   |  Date: 2004-05-12 10:05:21
   RE: ampli passe bande
Salut

Quelles sont les impédances de charge et de source du filtre?
(Sous 50 ou 75R, la structure n'est pas réalisable avec de simples composants L/C, il faudra utiliser des transfo, ce qui reste très classique)

A+

Numéro de l'article: 96704   |  De: SuperPapum   |  Date: 2004-05-12 10:19:32
   RE: ampli passe bande
je ne connait pas les impedance de charges du filtre ( comme les montages aissi bien amont que aval ne sont pas encore fixés )
par contre, je manque de notions dans ce domaine. qu'est ce que cela va changer exactement?..
Merci et A++

Numéro de l'article: 96823   |  De: Kyub!   |  Date: 2004-05-12 14:21:15
   RE: ampli passe bande
Salut

Vu ce que tu souhaites, ce filtre sera de type LC passif avec transformateur d'impédance. De fait, sa réponse est obligatoirement fixée par ses impédances de charge (comme tous les filtres passifs). Cela dit, dans nombre de récepteurs HF, les filtres d'entrées sont des étages actifs sélectifs. C'est une autre solution.
Ou se situe ce filtre dans la chaine de réception ?

A+

Numéro de l'article: 96855   |  De: SuperPapum   |  Date: 2004-05-12 15:11:11
   RE: ampli passe bande
salut...
le filtre passe bande se situe juste apres un préampli (AOP monté en inverseur).
pour l'adaptation d'impédance, je peux utilisé un montage suiveur?
merci de ta réponce
a+

Numéro de l'article: 96870   |  De: Kyub!   |  Date: 2004-05-12 15:26:34
   RE: ampli passe bande
Salut

Un AOP en suiveur à 70 MHz, c'est un peu osé. Tu vas effectivemment trouver des composants capables de traiter une telle fréquence mais ils sont en général très bruyants. Or la recherche du bruit mini est impérative dans un récepteur.

A+

Numéro de l'article: 96937   |  De: SuperPapum   |  Date: 2004-05-12 17:55:14
   RE: ampli passe bande
HelloO...
j'ai réalisé le montage et ca marche sans probléme...
Merci SuperPapum,tes conseils m'ont bien aidés
@pluche et bonne journée

Numéro de l'article: 97624   |  De: Kyub!   |  Date: 2004-05-14 10:15:44

   VIRUS  
coucou les mec le boss à contracter un virus qui s'appelle BACKDOOR.SD, le symptome est que le pc redemarre quand on est sur le net.

Numéro de l'article: 96687   |  De: alex.com   |  Date: 2004-05-12 09:48:48
   RE: VIRUS
c est pas plutot sasser?

Numéro de l'article: 96695   |  De: EEA   |  Date: 2004-05-12 09:58:52
   RE: VIRUS
" ca sert " à rien d'en parler

Numéro de l'article: 96703   |  De: didier   |  Date: 2004-05-12 10:16:52
   RE: VIRUS
sa ressemble a sasser effectivement. Comment on fait pour le gicler??

Numéro de l'article: 96705   |  De: alex.com   |  Date: 2004-05-12 10:24:23
   RE: VIRUS
sous google
patch sasser

Numéro de l'article: 96710   |  De: EEA   |  Date: 2004-05-12 10:30:03
   RE: VIRUS
tu peux aller sur www.secuser.com, y'a plein de trucs super dedans...

Numéro de l'article: 96778   |  De: Géale   |  Date: 2004-05-12 12:04:19
   RE: VIRUS
change pour un OS moin sensible au virus et au faille...

Numéro de l'article: 96845   |  De: Tux   |  Date: 2004-05-12 15:00:30

   "double "pour eeprom?  
salut!
c'est encore moi avec mon eeprom...
est-il possible d'envoyer n "double" sur une eeprom?
en fait je voudrai envoyer un chiffre tel que 2.365214 dans mon eeprom et ensuite venir relire ce meme chiffre...
estce que c'est possible, ou l'eeprom ne peut que recevoir des "int"???
merci pour vos réponses...
nico

Numéro de l'article: 96691   |  De: nico   |  Date: 2004-05-12 09:52:35
   RE: "double "pour eeprom?
lol, la question qui tue...
Ben oui, c'est possible... ton eeprom ne prend que des octets si elle est en huit bits... mais rien ne t'empeche par exemple d'ecrire ta valeur en ascii dedans par exemple les caracteres :
'2', '.', '3', '6', '5', '2', '1', '4'....
C'est la méthode la plus simple... Sinon vu la résolution que tu souhaites 10-6, tu peux utiliser un codage sur 24 bits, en fractionnaire... Soit seulement 3 octets pour stocker tes valeurs...

Numéro de l'article: 96694   |  De: pazcal   |  Date: 2004-05-12 09:57:51
   RE: "double "pour eeprom?
en fait, moi j'ai une valeur sur 10bits (j'utilise le can...) qui me sort donc des valeurs telles que 3.2154689 et je voudrai le sauvegarder dans l'eeprom et le lire aprés or j'y arrive pas...
j'ai par contre un prog qui lui marche avec des valeurs comprises entre 0 et 256...
je sais pas comment transformer cela en chiffre a virgule...


Numéro de l'article: 96700   |  De: nico   |  Date: 2004-05-12 10:09:02
   RE: "double "pour eeprom?
du moins non,je me sui strompé, c'est des valeurs comprises entre 0 et ff....désolé..


Numéro de l'article: 96701   |  De: nico   |  Date: 2004-05-12 10:10:09
   RE: "double "pour eeprom?
le morceau de prog qui suit me permet d'ecrire des valeurs comprise entre 00 et ff dans un espace mémoire compris entre 000 et 7ff

or, en ce qui me concerne, je voudrai pouvoir écrire des valeurs telles que 2.365474.. dans le meme espace mémoire que celui qui marche déja...
le seul probleme est donc de pouvoir changer la valeur à écrire...
si quelqu'un peut me dépatouiller, ca serai cool!!!
merci!!
voici le prog:
void init_ext_eeprom();
void write_ext_eeprom(long int, byte);
void read_ext_eeprom(long int);
#include <input.c>
//#include <2416.c>


main()

{

byte value,cmd;
EEPROM_ADDRESS address;

init_ext_eeprom();

do {
do {
printf("\r\nLire(L) ou Ecrire(E): ");
cmd=getc();
cmd=toupper(cmd);
putc(cmd);

while ( (cmd!='L') && (cmd!='E') );

printf("\n\rIndiquer l'adresse (entre 000 et 7ff): ");

#if sizeof(EEPROM_ADDRESS)==1
address = gethex();
#else

#if EEPROM_SIZE>0xfff
address = gethex();

#else
address = gethex1();
#endif
address = (address<<8)+gethex();
#endif

if(cmd=='L')
printf("\r\nValeur lue: %X\r\n",READ_EXT_EEPROM( address ) );

if(cmd=='E')
{
printf("\r\nNouvelle valeur a ecrire (entre 00 et ff): ");
value = gethex();
printf("\n\r");
WRITE_EXT_EEPROM( address, value );


while (1);



void init_ext_eeprom()
{
output_float(eeprom_scl);
output_float(eeprom_sda);



void write_ext_eeprom(long int address, byte data)
{
i2c_start();
i2c_write((0xa0|(byte)(address>>7))&0xfe);
i2c_write(address);
i2c_write(data);
i2c_stop();
delay_ms(11);


byte read_ext_eeprom(long int address)
{
byte data;
i2c_start();
i2c_write((0xa0|(byte)(address>>7))&0xfe);
i2c_write(address);
i2c_start();
i2c_write((0xa0|(byte)(address>>7))|1);
data=i2c_read(0);
i2c_stop();
return(data);



Numéro de l'article: 96727   |  De: nico   |  Date: 2004-05-12 10:53:24
   RE: "double "pour eeprom?
ohlala si ton CAN sort du 10 bits tu stocke AVANT conversion en float cette valeur en un byte LSB et 2 bits reportés dans un byte MSB
pourquoi faire simple quand on peut faire compliqué ...

Numéro de l'article: 96792   |  De: tgq   |  Date: 2004-05-12 12:23:37
   RE: "double "pour eeprom?
ok, je débute en prog, c'est pour cela...
tu pourrais mieux m'expliquer...
un exemple si tu peux...
merci beaucoup!!!

Numéro de l'article: 96810   |  De: nico   |  Date: 2004-05-12 13:29:50
   RE: "double "pour eeprom?
mais pour l'instant je suis pas avec mon can, je voudrai taper une valeur au clavier style 2.32141... et que celle-ci aille dans l'eeprom et pouvoir ensuite aller la lire...
merci de ton aide

Numéro de l'article: 96811   |  De: nico   |  Date: 2004-05-12 13:32:27
   RE: "double "pour eeprom?
surtout que sur 10 bits, la meilleure resolution que tu puisses avoir, c'est 0.0001... en non signe avec une valeur maxi d'environ 0.999... donc je doute que tu puisses obtenir 3.2154689 avec un can sur 10 bits... donc essaye de mettre un peu d'ordre ds tout ca.. et dis toi bien qu'une eeprom n'est qu'une mémoire, qu'elle soit sur 1/8/16/ou meme 512 bits n'a aucune importance, ca reste de la memeoire, et tu stockes tes donnes comme tu le desires... il suffit de choisir la methode de codage apropriee...

Numéro de l'article: 96867   |  De: pazcal   |  Date: 2004-05-12 15:23:30
   RE: "double "pour eeprom?
ok c'est pas grave, on se comprend pas je crois....
je ne parle plus du convertisseur 10bits pour l'instant!
je cherche juste a envoyer une donnée (float je pense) telle que 2.325 dans ma mémoire eeprom et venir la lire par la suite , voilà, je crois que je peux pas etre plus clair que ça...
merci si vous pouvez vraiment m'aider..


Numéro de l'article: 96877   |  De: nico   |  Date: 2004-05-12 15:38:18
   RE: "double "pour eeprom?
ben oui tu peux.... un float c'est olbigatoirement code sur des entiers... la memoire a virgule ca n'existe pas encore... mais tant que tu connaitras pas le format de tes données ca risque d'etre dur... un float, ou un fractionnaire peut etre code sur 8/16/24/32/40/48/64 bits etc etc.... donc c'est toujours toujours toujours des octets.... donc aucun probleme.....Surtout que sur ton pic, si tu utilises des float alors que le cpu est entier tu es oblige de mémoriser mantisse et exposant et ca ca dépend de la lib math utilisee....

Numéro de l'article: 96923   |  De: pazcal   |  Date: 2004-05-12 17:16:31