ABCelectronique : portail d'information dans le domaine de l'électronique
Home » Diverses rubriques » Archive forum sujets+corp
 
     
   de 12V à 5V  
bonjour,
je travail sur ce petit montage pour delivrer une tension variant de 0 à 5V à partir d'une tension variant de -12V à +12V (en fait c'est la sortie d'un AOP utilisé en comparateur).
il est pret, je pense qu'il fonctionne, mais je n'arrive pas a le simuler sur pspice car il faut surement parametrer les deux diodes. je n'arrive donc pas à savoir si les valeur de mes composants sont juste ou pas, mais comme il ne s'agit que d'une resistance de protection je ne pense pas que ça pose probleme si j'utilise une 1k.
connaitriez vous un logiciel qui me permettrai de simuler mon montage. merci
###Graphgr_1142###

Numéro de l'article: 85901   |  De: gigi   |  Date: 2004-04-10 12:30:21
   RE: de 12V à 5V
le probleme de la simulation c est que si tu claque ta diode il te le diras pas . Il faut donc que tu calcul en fonction du courant qui traverse ta zener et la puissance qu'elle peut dissiper

Numéro de l'article: 85905   |  De: laurent   |  Date: 2004-04-10 12:48:22
   RE: de 12V à 5V
ok merci, gros detail que j'avai oublié.
merci

Numéro de l'article: 85906   |  De: gigi   |  Date: 2004-04-10 12:53:21
   RE: de 12V à 5V
pourquoi pas un max232 ?

Numéro de l'article: 85908   |  De: manu   |  Date: 2004-04-10 12:56:26
   RE: de 12V à 5V
A première vue je ne vois pas comment ce montage peut fonctionner quand Ve est négatif.
Mais peut être as tu prévu de placer des diodes l'entrée en pont ou en redressement mono alternance?

Numéro de l'article: 85961   |  De: Cub   |  Date: 2004-04-10 19:34:47
   RE: de 12V à 5V
Ben la diode zener est en inverse , la diode normal est bloqué, la résistance de 1K en sortie impose le 0.

Un problème purrait venir du courant de sortie trop important!!


Numéro de l'article: 86016   |  De: edouard   |  Date: 2004-04-11 00:54:24
   RE: de 12V à 5V
Moi je verrais plutôt quelque chose de comme ça:
(comme Cub)



Numéro de l'article: 86042   |  De: LUDOVIC   |  Date: 2004-04-11 10:15:12
   RE: de 12V à 5V
Moi je verrais plutôt quelque chose de comme ça:
(comme Cub)



Numéro de l'article: 86044   |  De: LUDOVIC   |  Date: 2004-04-11 10:16:17
   RE: de 12V à 5V
Un pont de graëtz puis une zener de 5v1 comme dis Cub c'est une bonne idée aussi. Par contre la sortie de l'AOP ne délivrera pas beaucoup de courant alors attention à ce que tu souhaite mettre en aval!


Numéro de l'article: 86045   |  De: LUDOVIC   |  Date: 2004-04-11 10:19:34
   RE: de 12V à 5V
Bonjour

pourquoi ne pas changer les paramètres de ton AOP pour qu'il te sorte directement le 0-5V au lieu de -12/+12 ,

Tu ne dis pas si c'est une sortie analogique ou tout ou rien.

A bientôt

Numéro de l'article: 86054   |  De: EPERVIER   |  Date: 2004-04-11 11:04:49

   CAN  
Bonjour , je suis en 1° année de prepa .
Je dois réaliser un tpe sur la CAN(conversion analogique numérique) .
Mais je n'arrive pas du tout à décoller . Pour mon expérience , j'avais penser à numériser un signal sinusoidal issu d'un gbf .
Donc on ferait un pont(meme plusieurs) diviseur de tension et a chaque niveau on mettrait une LED .
Exemple de 0 a 10 V : chaque niveau fait 2 V
0->2
2->4
4->6
6->8
8->10

et notre but est de montrer que la numérisation s'effectue grace a l'allumage des LEDS ou non .

Pourriez vous m'aider , je ne sais pas du totu quel montage faire , quels AO prendre ni les valeurs des resistances.

Numéro de l'article: 85902   |  De: DESREUMAUX Rémi   |  Date: 2004-04-10 12:36:40
   RE: CAN
Pourquoi ne prendrais tu pas un convertisseur tout fait...? Le but de ta manip, c'est de montrer l'echantillonnage, ou de faire un echantillonneur?
Parce que dans ton cas, tunn'aurais pas un vrai echantillonneur, mais plutot un chenillard, donc ce n'est pas un comptage binaire... Car une led ne peus s'allumer que si la precedente est allumée, et les seules valeurs possibles seront donc 2**n -1 => 1,3,7,15,...

Numéro de l'article: 85919   |  De: pazcal   |  Date: 2004-04-10 14:07:46
   RE: CAN
regarde au niveau des lm3914 ou des CAN ( autrement appellé ADC ) en sortie parallèle... :)

Numéro de l'article: 85922   |  De: manu   |  Date: 2004-04-10 14:32:57
   RE: CAN
Donc j'ai choisi un montage parallèle .
Au niveau de l'échantillonage , je ne sais pas du tout comment faire pour fixer une "horloge" ou base de temps .
Sur les montages en série , il est écrit clairement horloge mais pas sur les paralleles .

parallele : http://transdata.free.fr/images/can10moyen.jpg
Il est ecrit 30ns mais comment cette base de temps est elle "fabriquée"? (est ce la vitesse du courant ?:-))



Jerome , un collegue asiatique , a dit qu'il n'y avait pas besoin de s'occuper de cette base de temps car notre tpe ne s'interesse pas a la suite de la pseudo numérisation du signal , notre seul intéret est de montrer un signal numérisé (avec les leds)

Imaginez une led a chaque sortie qui s'allume si la sortie est a 1 ou 0 .... Le signal sinusoidal entré est devenu numérique !!!
Et on ne sait absolument pas occupé de taux d'échantillonage ni de quantification .

Qu'en pensez vous?


Cliquez ici pour ouvrir l'image


Numéro de l'article: 86751   |  De: DESREUMAUX   |  Date: 2004-04-14 13:44:50
   RE: CAN
personne peut vraiment m'aider?

Numéro de l'article: 87159   |  De: remi d   |  Date: 2004-04-15 13:32:50
   RE: CAN
aidez le svp, il a l'air desespéré !
le seul truc que je peux faire pour toi, c'est faire remonter le message ds la liste

Numéro de l'article: 87329   |  De: cedric   |  Date: 2004-04-15 19:13:03

   lecteur dvd  
salut à tous!
j'ai un probleme avec mon lecteur dvd rom
la lecture de dvd est impossible a chaque fois que j'en met un j'ai un message d'erreur c'est comme si il manquait un decodeur ou quelque chose dans le genre pour demarrer la lecture sachant qu'un ami a foutu le bordel dans mon ordi(il aurai mieux fait de se casser une patte ce jour là!) bref est ce que quelqu'un peut m'aider?
autrement le lecteur très bien pour les autres format cd musicaux, mp3...merci d'avance!

Numéro de l'article: 85912   |  De: fredo   |  Date: 2004-04-10 13:33:46
   RE: lecteur dvd
Salut
il te manque surement quelque driver pour le soft de ton DVD essai de reinstaller toute la partie software de ton DVD ca devrait refonctionner...
Tux


Numéro de l'article: 85923   |  De: Tux   |  Date: 2004-04-10 14:33:51
   RE: lecteur dvd
Il aurait pas changé la zone de ton DVD ? Je ne sais pas comment réagit un lecteur si on lui met un DVD d'une autre zone...

Jar-jar alias Dim

Numéro de l'article: 86030   |  De: Jar-jar   |  Date: 2004-04-11 09:21:44

   electronique et mac  
salut à tous,

je me demandais si il existait des solutions pour faire de l'electronique sur mac (programmation PIC , ou saisie de schémas, routage)...
Je connais le site de macbrusoft, mais pas tellement d'autres choses...

vala,

merci d'avance de vos réponses...



Numéro de l'article: 85918   |  De: paul   |  Date: 2004-04-10 14:07:11

   prog68hc11 de edsoft à petitours  
après bien des recherches,j'ai trouvé pourquoi le talker ne chargait
pas .la prise db9 qui relie au max232 a été interpretée à l'envers
a vis à l'application du no 12 d'interface station météo
bonnes paques àtous !petitours merci

Numéro de l'article: 85924   |  De: bureau   |  Date: 2004-04-10 14:34:10
   RE: prog68hc11 de edsoft à petitours
forecement ca marche moins bien...

Content que tu sois content

bonnes paques

Numéro de l'article: 85983   |  De: petitours   |  Date: 2004-04-10 20:44:09

   De 6V à 13V  
Bonjour, je ne sais quel resistance mettre pour avoir 13V en sortie sur le LM 117 !!

Merci d'avance

Numéro de l'article: 85928   |  De: thomas   |  Date: 2004-04-10 15:08:44
   RE: De 6V à 13V
meme topo que sur les lm317...

Numéro de l'article: 85930   |  De: manu   |  Date: 2004-04-10 15:15:37
   RE: De 6V à 13V
Salut
je comprend pas trop ta question la...
tu veu utiliser un LM117 pour passer une tension d'entrée de 6V et en sortie 13V si oui c'est impossible... pour les regulateur de ce type il faut une tension plu elevé en entré que la sortie !
pour obtenir du 13V a partir de 6V ta 2 solution :
la plus simple pour de petit courant la pompe de charge...
pour de plus gros courant un regulateur a decoupage de type boost a partir d'un TL497...
Tux

Numéro de l'article: 85931   |  De: Tux   |  Date: 2004-04-10 15:17:14
   RE: De 6V à 13V
Ok, mais quel resistance mettre ??Combien d'ohm

Merci d'avance

Numéro de l'article: 85932   |  De: thomas   |  Date: 2004-04-10 15:17:18
   RE: De 6V à 13V
C'est quoi la pompe de charge ??


Numéro de l'article: 85933   |  De: thomas   |  Date: 2004-04-10 15:18:02
   RE: De 6V à 13V
c'est un petit montage qui a partir d'un oscillateur te permet d'obtenir soit un double de la tension ou plus suivant le nombre d'etage ou d'obtenir une tension negative suivant la disposition des condos.
Tux


Numéro de l'article: 85934   |  De: Tux   |  Date: 2004-04-10 15:20:45
   RE: De 6V à 13V
Ok merci!!Tux

Mais tu connais les ""ingrédients"" pour faire ca !!

Numéro de l'article: 85935   |  De: thomas   |  Date: 2004-04-10 15:21:40
   RE: De 6V à 13V
un tl497... ou un 555 si tu veux bidouiller...
regarde la :
http://perso.wanadoo.fr/sam.electroastro/dossiers/555/555.htm

Numéro de l'article: 85936   |  De: manu   |  Date: 2004-04-10 15:27:41
   RE: De 6V à 13V
Avec une petite alim à découpage très simple à faire
wulfman.com/pdffiles/mc34063.pdf
MG

Numéro de l'article: 85958   |  De: MG   |  Date: 2004-04-10 19:24:59
   RE: De 6V à 13V
je pense que ton MC34063 fera l'affaire sinon merci a tous les autres pour votre participation !!

A+ et bon montage

Numéro de l'article: 86738   |  De: thomas   |  Date: 2004-04-14 13:06:44

   recherche LED n°172  
salut,

eh oui j n ai plus le numero 172 qui est la premiere partie de l ampli du push pull avec la 845, et comme j aimerais bien lire la premiere partie avant de me lancer dans l aventure......
merci au personne de me repondre. merci d avance.
a+

Numéro de l'article: 85942   |  De: omartine   |  Date: 2004-04-10 15:59:00
   RE: recherche LED n°172
J' ai le numéro en question et je pourrai vous faxer l'article la semaine prochaine ? Contactez moi à chrgrasser@aol.com

Numéro de l'article: 86010   |  De: Christophe Grasser   |  Date: 2004-04-10 23:50:54

   Problème mise en route TV  
Bonjour, j'ai un TV Sanyo, mais la marque importe peu puisque j'avais il y a quelques années de cela une grundig avec le même souci et je l'avais changé pour ça ! Alors le problème est que quand je mets en route la TV, elle se coupe quasi tout de suite et passe en veille mais avec la diode d'indication de mise sous tension qui clignote. A force d'éteindre et de la rallumer avec la télécommande elle finit par se mettre en route au bout parfois de 20 minutes ! Que se passe t-il ? Quelqu'un peut-il m'aider ?

Merci à tous.

Numéro de l'article: 85946   |  De: Olivier   |  Date: 2004-04-10 16:10:16
   RE: Problème mise en route TV
Il me semble que tu as un probleme du 'standby',est ce que tu as l'habitude d'arreter le TV en mode veille, si c'est le cas arret ton appareil par le bouton M/A. J'ai réglé ce genre de problème de cette manière .

Numéro de l'article: 85953   |  De: THUEMLER   |  Date: 2004-04-10 18:07:20
   RE: Problème mise en route TV
Non, jamais je n'arrête la TV avec le mode veille, mais bien toujours par le bouton M/A. Donc...

Numéro de l'article: 85957   |  De: Olivier   |  Date: 2004-04-10 18:53:23

   magasin à paris??  
donnez-moi des noms de magasins et si possible leur adresse en informatique et en audio qui sont vraiment très bon marché (prix bas) de la capitale svp!

Répondez-vite !!!!

Merci à tous...

Numéro de l'article: 85948   |  De: pier   |  Date: 2004-04-10 16:59:03
   RE: magasin à paris??
répondez c urgen !!!!

Numéro de l'article: 85962   |  De: pier   |  Date: 2004-04-10 19:37:05
   RE: magasin à paris??
voir dans les revues d'electronique il y en a des masses

ou alors GOOGLE ou COPERNIC tu peux le faire tout seul sans avoir besoin des autres investi toi un peu

Numéro de l'article: 85971   |  De: piraylleur   |  Date: 2004-04-10 20:18:33
   RE: magasin à paris??
et sois plus cool la prochaine fois...

Numéro de l'article: 85986   |  De: manu   |  Date: 2004-04-10 20:52:38
   RE: magasin à paris??
vous n'etes pas sympa qd mem !

merci qd mem !

Numéro de l'article: 86021   |  De: pier   |  Date: 2004-04-11 07:58:42
   RE: magasin à paris??
si on est pas sympas la prochaine tu vas voir ailleur ou tu te débrouilles pour chercher ton magasin, en plus c'est pas ce qui manque a paris....

Numéro de l'article: 86023   |  De: manu   |  Date: 2004-04-11 08:12:14
   RE: magasin à paris??
Disons que ta façon de poser ta question n'est pas optimale...

Jar-jar alias Dim

Numéro de l'article: 86029   |  De: Jar-jar   |  Date: 2004-04-11 09:14:44
   RE: magasin à paris??
rue herold dans le 1er ou alors pres des grands magasins à cote de la fnac !

Numéro de l'article: 86095   |  De: Art   |  Date: 2004-04-11 18:01:01

   Imprimante HP  
Bonjour
je possede une imprimante HP 845 C et elle est en panne
je n'arrive pas a enlever le capot en plastic afin de verifier le problème
c'est sans doute une bêtise mais je ne vois pas la solution
QQ peux t il m'aider
D'avance Merci
Alain

Numéro de l'article: 85949   |  De: Alain   |  Date: 2004-04-10 17:15:50
   RE: Imprimante HP
sur ce type d'imprimante il utilise pas de vis pourquoi j'en sais rien c'est genre des clips tu les apuuie avec un tournevis plat et tu tire en meme temp... y'a 2 vis sur le chargeur papier je croi...
Tux


Numéro de l'article: 85967   |  De: Tux   |  Date: 2004-04-10 20:02:31
   RE: Imprimante HP
Salut !;

dans le même genre de questions je me permet d'en poser une...

J'ai une paire d'haut-parleur pour pc de marque "Diamond Audio technology"...

Et je n'arrive pas a ouvir le boitier ?!?!?...il n'y a pas de visses, apart ceux qui fixe le H-P...

Quelqu'un a déja demonter un truc du genre ?


Merci d'avance et désoler de poser ma questins sur ce topic, mais comme c'etait le meme genre je me suis permet ;o)...




Tronic-man.

Numéro de l'article: 85970   |  De: Tronic-man   |  Date: 2004-04-10 20:09:35
   RE: Imprimante HP
Tronic-man >> essai de voir si il y a de quoi passer un tournevis entre les 2 partie ( sans forcer trop...) c'est peut etre des clips de coté ou sinon au pire des cas il l'auront collé...
Tux

Numéro de l'article: 85976   |  De: Tux   |  Date: 2004-04-10 20:36:34
   RE: Imprimante HP
non malheureusement aucun clips, a mon avis tu a raison ils ont coller... assez embetant car si on force de trop avec un large tournevis plat le plastique "s'ecaille"...

Enfin je regarderais sa plus tard, quand je serai moi fatigué...

Bon soirée a tous.

Numéro de l'article: 85980   |  De: Tronic-man   |  Date: 2004-04-10 20:42:37
   RE: Imprimante HP
Salut
J'ai deja demonté ce genre de HP et il faut enlever la face avant
qui est maintenue par des clips donc en faisant une pression
avec un tournevis plat entre le bois et le plastic ou feutre avant tu devrais pouvoir les ouvrir
a +

Numéro de l'article: 85990   |  De: Alain   |  Date: 2004-04-10 21:01:28
   RE: Imprimante HP
ok, merci, sa j'ai reussi, mais comment dois-je faire pour "ouvrir" l'enceinte maintenant ?

Numéro de l'article: 86024   |  De: Tronic-man   |  Date: 2004-04-11 08:48:22
   RE: Imprimante HP
Enlèves les vis qui tiennent les HP's, il ce peut que tu aies assez de place pour accéder au reste par l'ouverture laissée par les HP's.

Par exemple, pour mes baffles de salon, c'est comme ça qui'il faut accéder à l'intérieur.

Jar-jar alias Dim

Numéro de l'article: 86028   |  De: Jar-jar   |  Date: 2004-04-11 09:11:58
   RE: Imprimante HP
oui, sa j'ai reussi, mais il y a "au fond" le CI ampli, et j'aimerais y accepter mais il est "clipser" dans le fond de l'enceinte et est rectangulaire (l prend la bas du boitier) je ne sais donc pas le sortir...

Bizzaarrrree...

Numéro de l'article: 86031   |  De: Tronic-man   |  Date: 2004-04-11 09:34:02

   Ch. doc Fr Protel 99se  
Je recherche une doc en français pour Protel99SE. Quelqu'un a ça ?
Merci.

Numéro de l'article: 85950   |  De: Max   |  Date: 2004-04-10 17:56:46
   RE: Ch. doc Fr Protel 99se
une doc non des réponses à tes questions sans doute! :)

Numéro de l'article: 86040   |  De: LUDOVIC   |  Date: 2004-04-11 10:12:12

   kit de liaison dvd rom  
bonjour a tous

je vous écrit car j'ai un soucis pour installer un kit de connection entre un ordinateur portable et une télé pour pouvoir regarder des DVD.

Il n'y a pas de notice d'explication et la marque est APM.

Alors s'il vous plait si vous pouvez me renseigner, cela serait vraiment trés aimable car je suis perdu !!!!!!

Merci d'avance !!!!


Numéro de l'article: 85955   |  De: alex   |  Date: 2004-04-10 18:27:54
   RE: kit de liaison dvd rom
salut;

tu veux connecter ton portable sur la tv, pour avoir l'image du dvd sur ton televiseur ?

alors tu relie la sortie video de ton pc a l'entree video de ton tv, et tu active la sortie vdeo du pc dans le option de celui ci...et voila...



CiAo.

Tronic-man.

Numéro de l'article: 85972   |  De: Tronic-man   |  Date: 2004-04-10 20:19:21
   RE: kit de liaison dvd rom
MERCI DU CONSEIL JE VAIS ESSAYER

A PLUS


Numéro de l'article: 86075   |  De: alex   |  Date: 2004-04-11 14:41:54
   RE: kit de liaison dvd rom
de rien, alors cela fonctionne ?

Numéro de l'article: 86179   |  De: Tronic-man   |  Date: 2004-04-12 10:14:23

   Concaténation chaine en C  
Bonjour à tous,
Je voudrais savoir comment peut on faire pour concaténer deux octets (8bits) en une chaine de 16bits

exemple:

OCTET_H = 11111111
OCTET_L = 00000000

CHAINE = OCTECT_H + OCTECT_L

CHAINE = 1111111100000000

Quelle instruction dois-je utiliser?
Comment doivent etre déclarer les variables? (bit, char, int, long int,...)
Quelles sont les librairies éventuelles?

Merci pour vos réponses!!!

Numéro de l'article: 85959   |  De: Mustang   |  Date: 2004-04-10 19:26:58
   RE: Concaténation chaine en C
Salut
rien de plus simple tu defini un tableau de 2 octets ensuite tu fait pointer un pointeur sur le premier octets du tableau par un pointeur de type short et le tour et jouer...
en gros ca donne :
unsigned char valeur[2];
unsigned short *ptr = (short *) valeur;
unsigned char *OCTET_H = &valeur[1];
unsigned char *OCTET_L = &valeur[0];
Tux

Numéro de l'article: 85964   |  De: Tux   |  Date: 2004-04-10 19:49:19
   RE: Concaténation chaine en C
oups j'ai oulier de dire que tu recupere ta valeur par le pointeur ptr...

piti exemple de l'utilisation :

#include <stdio.h>

int main(void)
{
unsigned char valeur[2];
unsigned short *ptr = (short *) valeur;
unsigned char *OCTET_H = &valeur[1];
unsigned char *OCTET_L = &valeur[0];

*OCTET_H = 255 /* 11111111 = 255 en decimal */
*OCTET_L = 0 /* 00000000 = 0 en decimal */
printf("Valeur de OCTET_H : %d\nValeur de OCTET_L : %d\nValeur
concaténé : %d",*OCTET_H,*OCTET_L,*ptr);
return 0;



ou alor plus simple vu que j'y pense now :

#include <stdio.h>
int main(void)
{
unsigned char OCTET_H = 255;
unsigned char OCTET_L = 0;
unsigned short resultat;
resultat = OCTET_H + OCTET_L;



Numéro de l'article: 85965   |  De: Tux   |  Date: 2004-04-10 19:58:29
   RE: Concaténation chaine en C
nan oubli ma dexieme solution chu fatigué moi loll

Numéro de l'article: 85966   |  De: Tux   |  Date: 2004-04-10 19:59:42
   RE: Concaténation chaine en C
OCTET_H = 11111111
OCTET_L = 00000000
CHAINE = OCTECT_H + OCTECT_L
CHAINE = 1111111100000000
ce que tu viens d'ecrire est faux!!!

Le resultat de CHAINE = OCTECT_H + OCTECT_L est 11111111

Donc en C tu fais

unsigned int16 chaine;//déclaration d'un integer sur 2 octets
unsigned int8 OCTET_H, OCTET_L;//déclaration d'un integer sur 1 octet

OCTET_H = 0xFF;//11111111 en hexadecimal
OCTET_L = 0x00;//00000000 en hexadecimal
CHAINE = (((int16)(OCTET_H)) << 8) + ((int16)(OCTET_L));

En fait tout dépend de ton compilateur, la, je l'ai écrit pour le compilateur CCS pour PIC
ce qu'il faut retenir c'est le <<8 sur l'octet_h et l'addition entre les 2.
le<<8, c'est décalage à gauche 8 fois. C'est comme si tu multipliais par 256

ce que j'ai fait avec les (int16)(), cela s'appelle caster, c'est a dire transformer les int8 en int16

Sam



Numéro de l'article: 85996   |  De: Sam   |  Date: 2004-04-10 21:35:16
   RE: Concaténation chaine en C
Sam a la bonne solution mais j'ai juste une petite critique sur :

CHAINE = (((int16)(OCTET_H)) << 8) + ((int16)(OCTET_L));

L'opérateur d'affectation '+' peu provoquer une erreur d'interprétation par comparaison surtout en nombre signé. Essai cette exemple pour voir :

/*----------------------------------------------------------*/
signed char A = 0xFF;
signed char B = 0xFF;

signed short int C = 0;

C = ((signed short int)(A << 8)) + (signed short int)B;
/*----------------------------------------------------------*/

et celui ci qui, est plus sur ! Le OU bit a bit fait que la pseudo concatenation que veux Mustang est mieux respecté.

/*----------------------------------------------------------*/
signed char A = 0xFF;
signed char B = 0xFF;

signed short int C = 0;

C = ((signed short int)(A << 8)) | (signed short int)B;
/*----------------------------------------------------------*/

Dans le premier cas le résultat est : FEFFh
Dans le second le résultat est : FFFFh

Je pinaille un peu car sur un micro-contrôleur et même autre part tout est en nombre signé et il y a que l'interprétation qu'on en fait qui change. J'ai déjà eu le tour et je peux vous dire d'expérience que c'est très difficile a debugger un problème de ce genre.

Mais si Mustang utilise ton exemple, Sam, alors il n'y aura pas de problème puisque tout les données utilisent le modificateur unsigned.

Voilà c'était juste pour info.
Vincent

Numéro de l'article: 86229   |  De: Vincent   |  Date: 2004-04-12 15:38:34
   RE: Concaténation chaine en C
J'oubliais de préciser que la variable 'C' doit être initialisée à 0 avant la pseudo concaténation.

Numéro de l'article: 86352   |  De: Vincent   |  Date: 2004-04-13 00:16:16

   anti-oublie electronique  
salut
Es ce que quelqu'un sait comment je peux avoir l'article complet
du n 277 année 2003 de électronique pratique. Sur cet article est décrit exactement l'objet que je veux réaliser , mais je ne peux pas obtenir le montage complet.Cette article décrit un systeme emetteur récepteur , si l'un seloigne trop de l'autre , le récepteur se met a sonner.
merci
a+


Numéro de l'article: 85963   |  De: xav   |  Date: 2004-04-10 19:38:26

   pic16c55  
est ce qu'il ya quelqu'un qui me donne une programme pour le pic16c55 pour foction un identificateur de l'appelant du téléphone fixe

Numéro de l'article: 85969   |  De: mehrez   |  Date: 2004-04-10 20:06:53

   Reparation ampli HiFi (debtant)  
Bonjour à tous,

Voila mon ampli (Marantz SR-50L) à rendu l'âme après 12 ans de bons et loyaux services. Ils semblerait que ce soit un (ou plus) des transistors de puissance qui soit mort.
J'ai ouvert le tout : fusible mort -> nouveau fusible = *pof* fusible mort à nouveau.

Je suis passé chez le reparateur qui m'a donc dit que c'etait les transistors qui etaient morts. Il me prenait autour de 1000 fr pour le raparer (!!). Es-ce que ces composants sont aussi chers ? Pensez vous que je puisse le réparer moi même (j'ai un multimetre et un fer à souder :) ).

La ref des transistors est :
- C3180n (noirs) il y en a 2
- A1263n (verts) aussi 2
- 2 plus petits noirs sans ref.

Ils n'ont pas l'air cramé d'exterieur. Puis-je les tester ? Comment ?

Voila merci pour avoir pris le temps de me lire et eventulement de m'aider :)





Numéro de l'article: 85977   |  De: alb404   |  Date: 2004-04-10 20:37:43
   RE: Reparation ampli HiFi (debtant)
salut,


oui à 70% , mais si on change les transitoors de puissance ,on change aussi les divers(petits qui controlent les gros).

pour les tester les dessouder et les mesurer à l'ohmmetre.

Numéro de l'article: 85984   |  De: neuneu57   |  Date: 2004-04-10 20:45:30
   RE: Reparation ampli HiFi (debtant)
Salut 1000fr pour reparer a ce prix la les contact des transitors sont en or !!! ou alor le reparateur s'en met beaucoup dans la poche...
pour tester tes transistor tu regarde si tu n'a pas un 0 entre les pattes du transistor a l'ohmetre...
pour info les 2 references de transistor ne depasse pas 2$ la piece... sachant que 1000f = environ 200$ tu peu t'en acheter des transistors loll
Tux


Numéro de l'article: 85985   |  De: Tux   |  Date: 2004-04-10 20:51:06
   RE: Reparation ampli HiFi (debtant)
Salut,

Es-ce obligatoire de les dessouder avant de les tester ? Quel valeur je dois avoir avec mon ohmmetre ?
Sinon dois-je les remplacer avec les même ? Et à quel coût ?

Merci !

Numéro de l'article: 85987   |  De: alb404   |  Date: 2004-04-10 20:53:54
   RE: Reparation ampli HiFi (debtant)
c'est conseiller de les dessouder pour ne pas que ta mesure n'interfere avec les autres composants sur le circuit.
pour la valeur tu doit trouver une valeur asser grande > au kilo ohm si tu a un 0 ou proche c'est qu'il est mort et paie a son ame...
pour les prix je t donner une aproximation plus haut.
Tux

Numéro de l'article: 85988   |  De: Tux   |  Date: 2004-04-10 20:59:34
   RE: Reparation ampli HiFi (debtant)
Merci pour le tuyau ! Bon je viens de les tester, sur les 4, 3 ont 0 entre les 2 pates (les 2 pates sur les cotés).

C'est donc ça le problème ?!

Numéro de l'article: 85989   |  De: alb404   |  Date: 2004-04-10 21:01:13
   RE: Reparation ampli HiFi (debtant)
ben du moin il font parti du probleme c'est sur qu'il sont mort maintenant avant de les changer par d'autre regarde si il n'y a pas d'autre transistor ou diode qui aurait pu lacher aussi.

Numéro de l'article: 85991   |  De: Tux   |  Date: 2004-04-10 21:03:44
   RE: Reparation ampli HiFi (debtant)
neuneu57 à ecrit :
Mais si on change les transitoors de puissance ,on change aussi les divers(petits qui controlent les gros).
Pourtant ils ont l'air en bon etat ....


Numéro de l'article: 85993   |  De: alb404   |  Date: 2004-04-10 21:16:35
   RE: Reparation ampli HiFi (debtant)
Et bé ... il y a du boulot ! :)

Numéro de l'article: 85994   |  De: alb404   |  Date: 2004-04-10 21:22:54
   RE: Reparation ampli HiFi (debtant)
Bonjour

Remplace toujours les 4 transistors de puissance

(2S)C3180 = BD245B ou C
(2S)A1263 = BD246B ou C

Pour essai(après avoir remplacé les 4 TR) tu places une lampe de 60 w en // sur le fusible claqué pour limiter le courant , si la lampe s'allume et s'éteint aussitôt, c'est OK ,
Tu dois mesurer sur les verts : au milieu -30V env
à gauche (les pattes vers toi, l'ndic au dessus) 0 v
à droite > -0.7 v
Sur les noirs idem mais en positif.
Entre les pattes de droite (noir et vert) 0.1V environ
Si tout cela est bon , tu peux remettre le fusible >> cela devrait marcher sinon continue à vérifier les transistors.
Bonne chance
A bientôt


Numéro de l'article: 86000   |  De: EPERVIER   |  Date: 2004-04-10 22:43:01
   RE: Reparation ampli HiFi (debtant)
Bon je viens de changer les 4 transistors, mis une lampe en // sur le fusible et elle s'allume mais ne s'éteint pas .. Et si je mets un fusible, il claque ...

Je suis à cours d'idées ...

Merci pour votre aide !

Numéro de l'article: 86542   |  De: alb404   |  Date: 2004-04-13 17:58:50

   prog. automat  
je suis à la recherche du logiciel pour TSX nano
Merci d'avance .

Numéro de l'article: 85978   |  De: pascal   |  Date: 2004-04-10 20:37:47

   panne tv thomson CC361V  
Bonjour,

J'ai un petit problème avec mon televiseur thomson, à froid je j'allume et il fonctionne 15 secondes après il s'éteint et tentative de démarrer toute les 2 secondes.
j'ai regardé tous les schémas classiques iccx etc... et je n'ai rien trouvé qui resemble.
a part un bout de schéma icc5, les commandes ligne de mon tele est faite par un tea2029 il a une tension en patte 28 elle devrait être à 0v, ce qui est peut être normal car l'oscillation en sortie du tea2029 monte en fréquence et en insistant la tht sifle.

Quelqu'un aurait une info sur le thomson cc361v, chassis schèma etc...

valerie.




Numéro de l'article: 85998   |  De: valerie   |  Date: 2004-04-10 22:17:20
   RE: panne tv thomson CC361V
Bonjour

as-tu fait le test de la lampe ?

A bientôt

Numéro de l'article: 86002   |  De: EPERVIER   |  Date: 2004-04-10 22:47:02
   RE: panne tv thomson CC361V
Bonjour ou bonsoir,
merci de ta réponse,
le test de ma lampe???
pour ma par je met (deux lampe de 100w parallèle) en serie avec le 220V pour les courts circuits mais dans mon cas ça ne sert à rien.
Je présume que le test de la lampe consiste à servir de charge quelque part???

Valerie



Numéro de l'article: 86011   |  De: valerie   |  Date: 2004-04-11 00:10:11
   RE: panne tv thomson CC361V
Bonjour

oui vas voir dans ton Email.

Les deux lampes de 100w en // ne font que protéger ton fusible d'entrée , ton Bu d'alim n'est pas protégé.

A bientôt

Numéro de l'article: 86048   |  De: EPERVIER   |  Date: 2004-04-11 10:41:38
   RE: panne tv thomson CC361V
comment protéger le bu (ou ts2000) d'alim?

Numéro de l'article: 86059   |  De: babak   |  Date: 2004-04-11 11:52:18
   RE: panne tv thomson CC361V
j'ai fais le test de la lampe, qui consiste à mettre une ampoule de 220V comme charge sur la tension d'alimentation THT (B+),j'ai soudé la lampe de 220V 60W à la place du BU ligne en collecteur emetteur, retirer le bu de préférence.

Ma panne est identique: conclution la THT ou les secondaires de la tht ne sont pas en cause.

les secondaires de l'alimentation mon l'aire bon.

alors je vais regarder je primaire de l'alimentation.

merci pour les informations d'EPERVIER.

je reste à l'écoute de se forum pour d'autre info

Valeris


Numéro de l'article: 86131   |  De: valerie   |  Date: 2004-04-11 20:06:18
   RE: panne tv thomson CC361V
Bonjour

Cmme je te l'ai dit dans mon mail , je péfère mettre la lampe en amont du transfo THT et de débrancher celui-ci pour bien s'en affranchir et ne pas fausser le diagnostic.
Si ton alim bat , vérifie la mise en sécurité de celle-ci ainsi que le retour pour alimenter son ci par le transfo d'alim.(Au départ le ci est souvent alimenté via une grosse résitance à partir du réseau.
Vérifie les résistances de fortes valeur et remplace les condos électrolytiques de l'alim.
Pour protéger le BU d'alim , il faut mettre une lampe de 100à 200w entre le condensateur du 300v et le transfo d'alim. Sinon la ùoidre petite pointe de courant demandée par le BU est supportée et donnée par le condo du 300v.
Je ne possède pas de schéma thomson.

A bientôt


Numéro de l'article: 86175   |  De: EPERVIER   |  Date: 2004-04-12 09:49:32
   RE: panne tv thomson CC361V
bonjour,

j'ai fais le test de la lampe en amont de la THT je resultat est le même le poste fonctione quelques seconde puis l'alimentation se met à battre.
j'ai regardé au primaire de l'alimentation, les résistance de démarage ainsi que les condensateurs electrochimiques sont bon, l'alimentation n'a pas de circuit integré, uniquement des transistors, je me penche sur les condensateurs céramique et plastique de l'oscillateur au primaire de l'alimentation.

valerie


Numéro de l'article: 86445   |  De: valerie   |  Date: 2004-04-13 13:14:19