ABCelectronique : portail d'information dans le domaine de l'électronique
Home » Diverses rubriques » Archive forum sujets+corp
 
     
   Reception serie sur 16F84  
Bonjour,

Je voulais essayer de faire une liaison RS232 avec un PIC 16F84 surlequel j'ai cablé un afficheur LCD qui lui fonctionne bien.
Le problème est au niveau de la liaison serie, en effet, le pic recoit correctement l'octet sauf le bit 0 qui lui est apparament toujours à 0 au premier caractere envoyé apres l'allumage et toujours à 1 pour les caracteres suivants.
Je vous donne mon code, si quelqu'un pouvait regarder un peu ce qui ne va pas:

j'utilise d'abord l'interruption sur RB0 pour detecter le bit de start a 0 puis je fais une tempo de 100µs pour attendre le milieu du bit de start et j'initialise ensuite le timer 0 pour avoir une interruption toutes les 208µs cad au milieu de chaque bit suivant (liaison à 4800 bauds)

intrb0
; detection front descendant du bit de start(0)

bcf INTCON,4 ; desactiver inter RB0

; tempo de 100µs
movlw .100
movwf tempo
temporb0
decfsz tempo,f
goto temporb0

; config timer0
movlw .51
movwf TMR0 ; prochaine inter TIMER0 ds 208µs

bcf INTCON,2 ; effacer flag debordement TIMER0
bsf INTCON,5 ; activer inter TIMER0

movlw .7
movwf cmptbit ; initialisation compteur de rotations

return

J'utlise ensuite l'inter timer0 pour lire le bit en cours de reception puis le placer dans l'octet de reception que je fais ensuite tourner jusqu'a recevoir mes 8 bits (normalement, car apparament le bit 0 ne passe pas).
J'ai aussi essayé d'initialiser mon compteur de rotations a 8 ce qui me paraissait plus logique mais le resultat est alors incohérent.

inttimer
movlw .51
addwf TMR0,f ; recaler TIMER0 pour boucle de 208µs

; mesure des bits
bcf carrecu,7 ; effacer bit en cours de reception
btfsc PORTB,0 ; mesure de RB0
bsf carrecu,7 ; mise a 1 du bit ds le caractere

decfsz cmptbit,f ; decremente le compteur de bits recus
goto bitsuiv ; aller au bit suivant

; fin reception octet, reinitialisation
bsf affich ; flag caractere pret pr affichage

bcf INTCON,1 ; effacer flag inter RB0
bsf INTCON,4 ; activer inter RB0
bcf INTCON,5 ; desactiver inter TIMER0

return

; bit suivant
bitsuiv
rrf carrecu,f ; rotation octet reception

return

Si quelqu'un peut prendre le temps de regarder mon code merci.

Numéro de l'article: 133113   |  De: Duffy76   |  Date: 2004-09-11 14:31:23
   RE: Reception serie sur 16F84
bjr

je connais rien en pic mais la méthode est la bonne.

par contre es tu sur de tes temps de calculs ?

en effet il faut pas que tu dérives trop sous peine de louper le dernier bit de l'octet ?



Numéro de l'article: 133207   |  De: coco34   |  Date: 2004-09-11 21:01:27
   RE: Reception serie sur 16F84
Bonsoir,
Et bien au niveau du bit de start je ne suis pas sur de me positionner exactement au milieu mais apres ma derive doit etre nulle (au pire 1 ou 2µs sur chaque bit qui dure quand mm 208µs).
Et surtout d'apres l'affichage du LCD c'est le bit 0 qui n'est pas bon donc celui recu en premier.......

Numéro de l'article: 133211   |  De: Duffy76   |  Date: 2004-09-11 21:08:35
   RE: Reception serie sur 16F84
bjr

la procédure au bit de start, il faut lancer une tempo pour etre positionné 1.5T après..

fais tu un clear en début de trame ?

es tu sur de tes décalages à cahque bit ?


Numéro de l'article: 133291   |  De: coco34   |  Date: 2004-09-12 10:09:34
   RE: Reception serie sur 16F84
Bonjour,
Je suis a peu pres sur de mes tempos (enfin je suis a peu pres sur de tout mais ca ne fonctionne pas correctement).
Pour mes decalages pas de probleme (hormis le nombre de boucles de decalage qui me parait etre plus important que ce que j'ai actuellement mais c en initialisant mon compteur a 7 que le resultat est le plus proche du vrai)(je n'ai que le bit 0 qui n'est pas positionné correctement lorsque j'initialise a 7 alors qu'a 8 les caracteres n'ont plus rien a voir).
Pr contre je ne vois pas ce que tu veux dire par un clear en debut de trame (g jamais touché au port serie av et pas trop non plus a un queconque protocole de communication).

Numéro de l'article: 133306   |  De: Duffy76   |  Date: 2004-09-12 11:22:16
   RE: Reception serie sur 16F84
et non je parle de faire un clear de tes registres du µC à chaque début de start...

moi quand je suis sur de mes tempos je suis sur à 100% faut calculer au plus près les instructions...

;*****************************************************************************
; PROGRAMME MACHINE A PERCER LES CIRCUITS IMPRIMES 9600 bauds
;*****************************************************************************
;rb1= Tx du PC RB0= RX du PC

DEVICE SX28L,OSC4MHZ,TURBO,STACKX,OPTIONX
RESET Start ; adresse de démarrage lors d'un reset
FREQ 4_000_000

;Define all symbols
Count1 EQU $08 ;pour la tempo de 52µs
portb EQU $10 ;registre du portb
DATA EQU $11 ;registre de la data de lecture
DATAOUT EQU $13 ;registre de la data de sortie
WATCH Count1,8,UDEC ; à enlever ?
trame equ $12 ;variable pour determiner le bit de la trame

Start mov rc, #%00000000 ;init du port C à zéro
mov !rc,#%00000000 ;tout le port C en mode output direction
mov rb, #%00000001 ;init du port b à zéro
mov !rb,#%11111110 ;le port b (rb7 à rb1 en entrée (TX du pc), rb0 en mode output direction)

Main mov portb,Rb ; lecture du port rb bit rb1 (txdupc)
jnb portb.1,DEBUTLECTURE; si rb1=0 on va LANCER LECTURE (bit de start)
jnb portb.3,PH ;butée percage position haute
;jnb portb.2,PB butée percage position basse
;jnb portb.4,NONbouton NON
;jnb portb.5,OK bouton OK
JMP MAIN

DEBUTLECTURE call tempo_52micro ;3cycles
mov trame,#08; init début trame
lecturetrame call tempo_102micro ;3cycles
clc;init de la carry à 0 1cycle
mov portb,Rb ;lecture du port rb bit rb1 (txdupc) 2cycles
snb portb.1 ;si rb1=0 on saute STC 1ou 2(saut)
STC ;mise à 1 de la carry
jc coco ;2 4 si saut
CLC ;mise à 0 de la carry 1 cycle
coco RR DATA ;décalage à droite 1 cycle
decsz trame ;dec trame et saute JMP si trame=0 (MSB arrivé) 1 ou 2 si saut
jmp lecturetrame; retour début de lecture 3 cycles
call tempo_102micro ;3cycles
cje DATA,#$FF,rouge ; si 255 mettre RC7 à 1 led rouge
CJe data,#$57,verte ; si 87 mettre Rc4 à 1 led verte
cje data,#$fd,pasrouge ; si 253 mettre RC7 à 0 led rouge eteinte
cje data,#$58,pasverte ; si 88 mettre RC4 à 0 led verte eteinte
JMP MAIN ; retour à main

rouge setb rc.7
JMP MAIN
verte setb rc.4
JMP MAIN
pasrouge clrb rc.7
JMP MAIN
pasverte clrb rc.4
JMP MAIN


TEMPO_52micro mov Count1,#$34 ;Initialize Count1 à 52 (dec)2cycles
:temp decsz count1 ; 1 cycle
jmp :temp ; 3 cycle
ret
TEMPO_102micro mov Count1,#$66 ;Initialize Count1 à 102 (dec) 2 cycles
:temp decsz count1 ; 1 cycle
jmp :temp ; 3 cycle
ret


PH mov DATAOUT,#$33 ; preparation de la data de sortie
call debutenvoie ; lancement du prog d'envoie
JMP MAIN; retour prog principal
;********************************************************
;* sous programme d'envoie d'une data *
;********************************************************

debutenvoie clrb rb.0 ; mise à 0 du bit RX du pc (bit de start)
mov trame,#09; init début trame
envoietrame call tempo_102micro
rr dataout; décalage à droite pour mettre ds la carry le bit a expedier
snc ; teste la carry et saute la mise à 1 si C=0
setb Rb.0 ; mise à 1 du bit RX du PC
sc ; teste la carry et saute la mise à 0 si c=1
CLRB RB.0 ; mise à 0 du bit RX du PC

decsz trame ;dec trame et saute JMP si trame=0 (MSB expédié) 1 ou 2 si saut
jmp envoietrame; retour
setb Rb.0 ;mise à 1 du bit (bit de stop)
call tempo_102micro
;CLRB RB.0
ret; fin de l'envoie d'une trame
;********************************************************
;* fin sous programme d'envoie d'une data *
;********************************************************



Numéro de l'article: 133341   |  De: coco34   |  Date: 2004-09-12 13:22:43

   Elevation de tension  
Bonjour,

Je cherche une solution simple pour elever une tension de 5Vcc en 9Vcc. Si quelqu'un à ma réponse.

Merci d'avance

Numéro de l'article: 133114   |  De: Fabien   |  Date: 2004-09-11 14:44:09
   RE: Elevation de tension
Salut,
va voir les réponces que j'ai données pour 'blocking oscillator'
cd

Numéro de l'article: 133125   |  De: cd   |  Date: 2004-09-11 16:04:37

   pour le web master  
Bonjour,
Pour le sujet ‘explication allumage moto’ du 10-09-04, le compteur de réponse est à zéro (au 11-09-04 à 16h), hors il y en a plusieurs !
cd


Numéro de l'article: 133126   |  De: cd   |  Date: 2004-09-11 16:14:03
   RE: pour le web master
en fait je crois qu'il y a un déclage à partir d'un post...
d'un cran seulement , mais ça fout le bronx

Numéro de l'article: 133248   |  De: nico31   |  Date: 2004-09-12 00:07:40

   a l'intention de pym panne chassis AK12-9  
Aprés toutes les verifications concernant les circcuits de demarage
et d'auto alimentation ,seul apparement la résistance fusible
R809 etait claqué .Aprés echange de celle-ci 0.47ohm ,a la mise
sous tension elle a reclaqué et meme fortement ???
Ce peut-il qu'il y est une maniere speciale pour changer cette résistance ou y a t'il un court circuit plus loin .
Mais ou apparement le BU de ligne n'est aps en court circuit
serait ce possible que ce soit la THT qui soit en court circuit
Merçi de l'aide que l'on m'apporte.
http://www.dede75007.com/schemascouleur/aversb.html

Numéro de l'article: 133137   |  De: morel   |  Date: 2004-09-11 17:03:48
   RE: a l'intention de pym panne chassis AK12-9
si R809 largue je ne vois pas ce que tu vas faire sur le transistor ligne c'est le BU Alim qui doit etre defectueux Q801 ( BUZ90)

j'ai l'impression que tu ne doit pas connaitre grand chose en TV
aussi je pense que tu ferais mieux de t'adresser à un service apres vente pour te le faire reparer ( c'est leur metier à eux )

Numéro de l'article: 133160   |  De: bricoleur patenté   |  Date: 2004-09-11 18:04:25
   RE: a l'intention de pym panne chassis AK12-9
OK
Autant pour le BUZ90 est bien en court circuit
et je ne sais pas ce que j'ai foutu dans ma tête
L"electronique me passionne et je demandait un peu
que tu m'a rendu et je t'en remercie je vais donc
changer tous ces composants et verifier tout ,
comme cela je m'endormirais moins bête.
Tous cela pour que ce n'est parce que on n'est pas un douai en electronique qu'on a pas le droit de s'y interresser .
Je signale au passage quand essayant de reparer cette tele
j'en est appris beaucoup et que je commence a bien comprendre
l'alimentation primaire Merçi encore car c'est de l'aide que je demandait et non des mauvaises desobligences
Merçi encore pour le renseignement et de la leçon ..
A+++ Quand j'aurais changé le BU et la résistance peut aurais -je
encore besoin de vos service.

Numéro de l'article: 133184   |  De: morel   |  Date: 2004-09-11 19:59:40
   RE: a l'intention de pym panne chassis AK12-9
juste une remarque IMPORTANTE
dans une télévison il se prmène des tension MORTEL
pendant le service:
alim a découpage
hacheur THT
et LA THT en générale 20 KV soit 20 000 V avec un courant MORTEL

de plus
APRES LA MISE HORS TENSION
la tension de charge du tube ( écran) Car c'est un gros condensateur THT persiste longtemps (plusieur jours) et possède une rémanace importante (du phénomène de pé,étration des éléctron dans le verre) tu décharge le tube tu attend quelque seconde et la tension remont a un potentiel dangerreux? il faut maintenier en courcircuit plusieur secondes

le condensateur du hacheur de l alim à décioupgae rest a un potentiel de plusieur centaine de volt( avec quelque risques)

alors si tu est passioné et que tu ne connait pas trop les téléviseurs
ATTENTION la il y a des rique grave

amicalkement, c'est comme ça que l'on aprend, en, bidouillant
tchuss zirconien

Numéro de l'article: 133333   |  De: zirconien   |  Date: 2004-09-12 13:07:07
   RE: a l'intention de pym panne chassis AK12-9
BONJOUR
je te remerçie zirconien
pour tes conseils que je prends trés bien en compte
je faisais déja attention
mais je le ferais encore plus dorénavant
C'est enforgeant qu'on devient forgeron.
Trés bon conseil*******

Numéro de l'article: 133361   |  De: morel   |  Date: 2004-09-12 14:46:51

   déchargeur 200 amp  

Bonjours,

Pour mon travaille j' ai besoin de réaliser un déchargeur supportent 200 A sur 13 V .C 'est un bloc de condensateurs qui alimente une sono embarquée dans des véhicules . Lors d' un demontage un outil est tombé sur le bus d' alimentation .

Merci de votre aide

Numéro de l'article: 133146   |  De: patrick   |  Date: 2004-09-11 17:39:03
   RE: déchargeur 200 amp
Bonsoir,

Si je comprends bien, un bloc de condensateurs est chargé sous 13v mais pouquoi 200A si le temps de décharge n'est pas important, disons 2S dans ce cas un contacteur ou un relais capable de tenir 30A en série avec une résistance de 0,5 ohms doit permettre de décharger les condos sans courant important.

A+

Numéro de l'article: 133155   |  De: patou149   |  Date: 2004-09-11 17:54:01
   RE: déchargeur 200 amp
Nous chargeons le bloc en une minute environ c' est pour cela qu' il faut 200 a .Nous alimentons 2 amplis de 200w et deux autre appareils

Numéro de l'article: 133166   |  De: patrick   |  Date: 2004-09-11 18:23:07
   RE: déchargeur 200 amp
Bonsoir,

Un peu de mal à comprendre, autre question quelle est la valeur du bloc de condensateurs ( en µF ou Farads).

A+

Numéro de l'article: 133178   |  De: patou149   |  Date: 2004-09-11 19:21:47
   RE: déchargeur 200 amp
Salut,
J'utilisais des lampes (de mêmes tension et puissance et série et //) pour décharger les bancs de condensateurs des variateur de fréquence (qui n'étaient pas des petites bêtes)!!
cd

Numéro de l'article: 133223   |  De: cd   |  Date: 2004-09-11 22:04:40
   RE: déchargeur 200 amp
Un tournevis en travers des bornes comme tu le di toi meme

Numéro de l'article: 133499   |  De: ludo21   |  Date: 2004-09-12 23:47:57
   RE: déchargeur 200 amp
Salut,
Le 'conseil' de ludo21 est à proscrire;
Pour 'Patrick'pourquoi te fixes-tu 200A, c'est défini comment?
cd

Numéro de l'article: 133577   |  De: cd   |  Date: 2004-09-13 10:58:17
   RE: déchargeur 200 amp
54 capas de 1200F 2.3 V en serie //
Chargées a 13.8 V sous 215 A a décharger en 15 M sans arc electrique
au branchement merci de votre aide



Numéro de l'article: 133698   |  De: patrick   |  Date: 2004-09-13 16:11:39
   RE: déchargeur 200 amp
Salut,
Quelle est donc le condensateur équivalent de ton montage en µF et en V qui devra être décharger sans arc en 15 minutes ?
cd


Numéro de l'article: 133704   |  De: cd   |  Date: 2004-09-13 16:19:46
   RE: déchargeur 200 amp
Bonsoir,

Tu es sûr de tes valeurs ; 54 capas de 1200F
6 capas série avec 9 cellules en // OK ???.
Ce qui donne 1800 F

Sachant que T (temps de décharge 63%)= R * C on obtient avec R = 0,1ohm et C= 1800F T = 0,1*1800= 180S . pour une décharge à 100% on prends 5T soit 900S = 15 mn.

Le courant en début de décharge est : I=13,8 / 0,1 = 138 A .
Il te faut un gros contacteur, mais cela existe

A+

Numéro de l'article: 133742   |  De: patou149   |  Date: 2004-09-13 17:39:20
   RE: déchargeur 200 amp
oui nous avons bien 54 capas de 1200f a 2.3 V pour un total de 1800F de marque Panasonic
elles sont montées dans des tubes .
Quoi comme contacteur .le temps de 15 M est assez important car nous avons pas beaucoup de temps .

Numéro de l'article: 133790   |  De: patrick   |  Date: 2004-09-13 19:08:22
   RE: déchargeur 200 amp
Bonsoir,

Comme contacteur, regardes chez des fabricants de matériel électrique :
Merlin Gerin, Legrand, hagger ou autre.

A+


Numéro de l'article: 133854   |  De: patou149   |  Date: 2004-09-13 21:40:53
   RE: déchargeur 200 amp
Salut,
Pour patou149 : à la décharge Ui = Ec * e^( - t / to) donc pour t = to , Ui = Ec * e^(-1) ou Ui = Ec / e ou Ec / 2,718 ou Ec * 0,368 .
C’est 36,8 % à la décharge et 63,2 % à la charge es-tu d’accord ?
RE calcul
Pour t = 3 * to on obtient Ui = 0,05 * Ec.( voir ci-dessus)
Pour to = (15 * 60 ) / 3 avec C = 1800 F chargé à 13,8 V on a
R = 0,17 Ohm. Résistance faite avec 1,2 m de Cu en 4 mm^2 , qui chauffera comme n’importe quelle autre résistance pendant environ 5 mim ! l’expérience montrera s’il est nécessaire de ventiler ce fil
Ipointe = 13,8 / 0,17 ou 82,8 A Voir schéma que je propose , dont les détails sont :
AB : 1,2 m de Cu en 4 mm^2 dénudé
DC : 1,2 m de Cu en 16 mm^2 isolé
Connexion par souliers de câble vis et écrous
Th : Thyristor 200 A / 200 V (à choisir)
Procédure :
Repérer les polarités du condensateur chargé à 13,8 V
Raccorder les points A au MOINS, B, C.
SW1 fermé et SW2 ouvert.
Raccorder le point D au PLUS.
Ouvrir SW1.
Donner une impulsion de 0,5 S pour fermer SW2.
Surveiller Am ~= 80 A au départ
Suivre U et I
Rem :c’est le courant de maintien Ih du thyristor qui fixera l’arrêt du courant ~= 0,2 A
Pour le premier test mettre un fusible de 100 A dont la résistance, (et celle de son porte fusible auront été mesurée).

cd

Cliquez ici pour ouvrir l'image


Numéro de l'article: 133886   |  De: cd   |  Date: 2004-09-13 23:04:38
   RE: déchargeur 200 amp
Salut,
sur mon schéma à thyristor, mettre le PLUS en D ( vers l'anode du thyristor),c'est évident mais j'ai oublié de l'écrire sur le schéma.
cd

Numéro de l'article: 133887   |  De: cd   |  Date: 2004-09-13 23:08:37
   RE: déchargeur 200 amp
Salut,
Le thyristor sera monté sur un dissipateur ventilé.
cd
Cliquez ici pour ouvrir l'image


Numéro de l'article: 133929   |  De: cd   |  Date: 2004-09-14 08:20:47
   RE: déchargeur 200 amp
Merci de ton aide cd pour ventillé le Th je peux le faire avec un
ventillateur allimenté avec les capas a décharger .
Sur ton texte tu marque de raccorder les points A au moins B C c'est bien cela je ne comprend pas trops ?
Comme switche je peux utiliser des commutateurs télémanique manuel?
Pour les résistances faut il quelles soient puissantes .



Numéro de l'article: 134244   |  De: patrick   |  Date: 2004-09-14 21:18:58
   RE: déchargeur 200 amp
Salut,
Bien sûr que tu peux utiliser la tension des condensateurs pour faire tourner un ventilateur qui refroidira le thyristor et très certainement qu’un autre ventilateur sera aussi nécessaire pour refroidir la résistance qui limitera le courant de décharge.(Voir calculs ci-dessous)
J’ AI COMMIS UNE ERREUR DE CALCUL. J’avais écrit « De A à B il y a un fil de cuivre dénudé de 1,2 m de longueur et de 4mm^2 de section »
C’EST FAUX il faudra 15 mètres de fils de cuivre dénudé ( car il chauffera) et de 1,5 mm^2 de section. Ainsi on aura une ‘Résistance’ de 0,17 Ohm.
Voir le lien si tu veux vérifier.
http://www.ac-bordeaux.fr/Pedagogie/Physique/Physico/Electro/e07fil.htm
Réalisation de la R de 0,17 Ohm voir ci-dessous (*)
Cette résistance (le fil rouge AB du schéma) aura à ses bornes juste à l’enclenchement :
(E cond. – Uth) ou (13,8 – 1,8) ou 12 V.
La connexion DC ( que j’ai raccourci de 1,2 à 1m c’est le fils bleu de Cu isolé de 16^2 de section) a une résistance de 0,001 Ohm
La somme des résistances vaudra avec les connexions par vis et écrous environ 0,2 Ohm
Donc le courant initial de crête vaudra 12 (V) / 0,2 (Ohm) = 60 A.
La résistance (fil rouge) à l’enclenchement dissipera P= R*I^2 ou 0,17* 60^2 = 612W
(Et environ 100 W après la constante de temps de 6 min.)
Le thyristor dissipera 1,2 * 60 = 72W. Le fil bleu dissipera 0,001 * 60^2 = 3,6 W
(*)Pour fabriquer la résistance de 0,17 Ohm.
Par exemple un support céramique de diamètre 5 cm et de 22 cm de longueur ou tout autre matériau résistant aux conditions imposées.
Enrouler au pas de 2mm le fils de 1,5 mm^2 (pas facile tu trouveras peut-être une autre méthode) et y mettre des connexions pour boulonner.
Pour SW1 et SW2 n’importe quel interrupteur fiable pour commuter 0,5 A sous 12V convient.
Pour la R de 100 Ohm ½ W suffit. Pour la R de 10 à (15 ohm max ) 1 W
Voici le schéma corrigé.
cd





Cliquez ici pour ouvrir l'image


Numéro de l'article: 134372   |  De: cd   |  Date: 2004-09-15 12:54:53
   RE: déchargeur 200 amp
Merci cd pour toutes tes explications alors pour ton information les
condensateurs sont dans un vehicule et le déchargeur doit être posé sur une table et être utilisé par des mécaniciens donc le plus simple possible a utiliser pour la longeur du cable de 15 m denudé j'ai peur que cela fasse désorde .

Numéro de l'article: 134426   |  De: patrick   |  Date: 2004-09-15 15:35:46
   RE: déchargeur 200 amp
Salut,
Il faut une Résistance de 0,17 Ohm qui dissipera 612 W à l’enclenchement et encore 100 W après 6 min. J’ai proposé une réalisation en bobinant le fil. IL NE FAUT PAS BOBINER mais la mettre en ZIGZAG car la version bobinée aura une inductance ‘L’ trop importante. Pour mettre à distance, voit le schéma où j’ai dessiné en brun les fils prolongateurs de 5 m max. chacun DC et D’C’ (en 16 mm^2 isolé) qui dissiperont chacun 18 W (3 W/m).
Il faut que le montage sur table soit stable, bien fixé, bien isolé thermiquement, pas de matériaux combustibles du genre bois plastique etc. Et bien ventiler la R de 0,17 Ohm disposée en ZIGZAG.


Cliquez ici pour ouvrir l'image


Numéro de l'article: 134514   |  De: cd   |  Date: 2004-09-15 19:28:41
   RE: déchargeur 200 amp
Salut Patrick
1) As-tu bien enregistré que la R de 0,17 Ohm devait être en zigzag et pas bobinée ?
2) Après 6 min il n’y aura plus assez de tension pour que les ventilateurs, pour ‘th’ et ‘0,17 Ohm’ puissent ventiler efficacement. IL FAUT DONC VENTILER EN PERMANENCE.
3) J’ai ajouté K1/1 et K1/2 par sécurité. Pour moi K1/1 doit déjà exister c’est ce qui fait partie du circuit de charge des 1800 F. Il faut s’assurer que la source qui charge soit déconnectée d’où le K1/2.
Voir le schéma adapté.
cd

Cliquez ici pour ouvrir l'image


Numéro de l'article: 134640   |  De: cd   |  Date: 2004-09-16 09:08:28

   Ampli qui FUME HELP!  
bonjour a tous,
j'ai débranché le haut parleur de mon ampli(guitare) pensant pouvoir prendre la tension qui sortait de l'ampli en marche avec instrument branché et actif ,qu'est-ce que j'avais pas fait là! de la fumée qui commence a sortir de l'ampli et malheureusement pas de fusible sur ce vieil engin!
j'ai donc démonté et je l'ai réallumé pour voir d'ou venait la fumée:
de la base d'une des lampes de l'ampli (pas du préampli),étincelles et fumée! (voir photo).
je bidouille mais ne connais pas grand chose dans les principes de fonctionnement et l'electronique en général .
Est-ce que quelqu'un peut me dire quoi changer ou quoi tester et me l'indiquer sur la photo?(si c'est possible bien sur)
Merci d'avance!
Phil.
Cliquez ici pour ouvrir l'image


Numéro de l'article: 133154   |  De: Phil   |  Date: 2004-09-11 17:48:16
   RE: Ampli qui FUME HELP!
quelles sont déjà les références des lampes ?

de plus je ne pense pas que cette lampe soit un ampli


je commencerai déjà par remplacer la lampe en question

Numéro de l'article: 133163   |  De: bricoleur patenté   |  Date: 2004-09-11 18:14:17
   RE: Ampli qui FUME HELP!
Salut,
Il y a une carbonisation ( le charbon à une faible résistance) entre deux électrodes du socle de cette lampe, la seul solution changer ce socle.
Il n'est pas recommandé de faire fonctionner un ampli sans sa charge!(haut-parleurs).



Numéro de l'article: 133165   |  De: Calorios   |  Date: 2004-09-11 18:19:46
   RE: Ampli qui FUME HELP!
Bonjour

Normalement si tu remets le HP , il ne devrait plus rien se passer et l'ampli devrait refonctionner comme si de rien n'était. Si tel n'est pas le cas >>suivre calorios et peut être remplacer aussi le transfo de sortie !

Comme dit calorios : Il n'est pas recommandé de faire fonctionner un ampli (A LAMPES !!!)sans sa charge!(haut-parleurs).

ceux à transistors peuvent très bien fonctionner sans charge (sauf ceux à transfo de sortie comme macintosh ??)


A bientôt

Numéro de l'article: 133173   |  De: EPERVIER   |  Date: 2004-09-11 19:07:59
   RE: Ampli qui FUME HELP!
c'est un 6AQ5w c'est une des deux lampes de l'ampli.
1 12ax7 au préamp et 2 6aq5w a l'ampli (les 6aq5 sont +ou- équivalentes aux 6l6 mais avec un support plus petit.(lampe rarement utilisée en ampli guitar on les trouvait il me semble dans les vieux tourne disque ...)
j'ai essayé avec une autre lampe et même chose!

Numéro de l'article: 133176   |  De: Phil   |  Date: 2004-09-11 19:19:24
   RE: Ampli qui FUME HELP!
en remettant le hp c'est pareil il y a quelque chose qu'a grillé snif...!

Numéro de l'article: 133177   |  De: Phil   |  Date: 2004-09-11 19:20:54
   RE: Ampli qui FUME HELP!
Salut,
Il faut changer le socle de cette lampe, la partie carbonisée est conductrice et provoque une sorte de court-circuit.
La 6AQ5 n'est pas équivalente à une 6L6 qui peu délivrer une puissante de 6.5 W en mono.
La 6AQ5 est équivalente a l'EL90 qui développe 4.5 W en mono et en push-pull comme sur ton ampli la puissance max est d’environ 10 W.


Numéro de l'article: 133188   |  De: Calorios   |  Date: 2004-09-11 20:14:33
   RE: Ampli qui FUME HELP!
.

Numéro de l'article: 133189   |  De: cestavoir   |  Date: 2004-09-11 20:17:36
   RE: Ampli qui FUME HELP!
donc il y aune erreur sur ta photo


Numéro de l'article: 133191   |  De: cestouvu   |  Date: 2004-09-11 20:19:42
   RE: Ampli qui FUME HELP!
et hop trop rapide

donc il y a une erreur sur ta photo

Cliquez ici pour ouvrir l'image


Numéro de l'article: 133192   |  De: cestouvu   |  Date: 2004-09-11 20:20:37
   RE: Ampli qui FUME HELP!
Quelle erreur?

Numéro de l'article: 133194   |  De: Calorios   |  Date: 2004-09-11 20:21:46
   RE: Ampli qui FUME HELP!
Lol, trop rapide aussi, il n'y avait pas encore l'image.
Effectivement, mais ça ne change pas le problême.

Numéro de l'article: 133196   |  De: Calorios   |  Date: 2004-09-11 20:27:21
   RE: Ampli qui FUME HELP!
Bonjour,
En retirant le Hp, tu as occasionné une augmentation de la haute tension, étincelle et carbonisation du carton bakélisé du support.
C'est lui qu'il faut changer.
Je confirme le diag de Calorios.
Salut.

Numéro de l'article: 133208   |  De: igloo   |  Date: 2004-09-11 21:05:54
   RE: Ampli qui FUME HELP!
Salut,
Le remplacant exact pour la 6AQ5 est bien la EL90 et pour la 12AX7 c'est une ECC83.

Numéro de l'article: 133216   |  De: Alain C   |  Date: 2004-09-11 21:28:30
   RE: Ampli qui FUME HELP!
moi je monterrais des supports en ceramique si tu en trouve...

Numéro de l'article: 133222   |  De: gregelec   |  Date: 2004-09-11 22:00:18
   RE: Ampli qui FUME HELP!

Exact "cestouvu" j'ai inverser, ta rectification est bonne,sorry!
y-a-t-il un moyen de nettoyer ou réparer ce support?
sinon merci "calorios" et les autres!



Numéro de l'article: 133274   |  De: Phil   |  Date: 2004-09-12 02:29:19
   RE: Ampli qui FUME HELP!
Non, pas de réparation possible, une fois carbonisé le support est transformé (par endroit) en carbonne conducteur.
Salut.

Numéro de l'article: 133276   |  De: igloo   |  Date: 2004-09-12 03:39:38
   RE: Ampli qui FUME HELP!
Bonjour,
La seule réparation de bon aloi est de changer ce support.
Tu peux en trouver sur des épaves (radio ou ampli) et dans des magasins d'électroniques.
Ils faut demander un support de tube du type Miniature à 7 broches pour châssis.



Numéro de l'article: 133286   |  De: Calorios   |  Date: 2004-09-12 09:28:53
   RE: Ampli qui FUME HELP!
Bien vu!
c'était bien le problème!
après un bon nettoyage et un petit "rapiéçage"maison (fibre de verre pour réparer les pots d'échapement) en attendant un nouveau socle,
ç'est reparti comme en 14!!
merci encore.
Phil.

Numéro de l'article: 134314   |  De: Phil   |  Date: 2004-09-15 02:10:08

   recherche schéma électrique  
SALUT

Je viens de griller l'ampli de ma voiture et lorsque je l'ai démonté je me suis apperçu qui avait seulement une résitance de cramée. Mais impossible de savoir sa référence
C'est pour cela que je suis à la recherche d'un shéma électrique de l'amplificateur.

Merci de répondre pour me guider dans ma recherche car pour l'instant je n'ai rien trouvé.

Amplicateur de marque "SOUNDSTORM"
Ref : F100.4
Puissance : 100W * 4 CH

Numéro de l'article: 133168   |  De: Mika   |  Date: 2004-09-11 18:26:15
   RE: recherche schéma électrique
Une résistance en entrée, ou sortie? Si c'est sur la sortie HP, regardes avec les autres voies, elles sont symétriques, tu devrais trouver sans mal... sinon, si c'est sur l'alim, il doit y avoir un blos de découpage, ou un convertisseur DC/DC... Regardes la ref du convertisseur, et essaye de toruver une note d'appli sur le site du constructeur, il y a de fortes chances pour que tu puisses retrouver ta fameuse résistance...
Bonne chance


Numéro de l'article: 133251   |  De: pazcal   |  Date: 2004-09-12 00:12:48

   driver linux  
salut
je dois instaler linux sur disque scsi, j'ai besoin driver pour carte tekram dc 390, erst ce que vous savez ou je peux trouver driver
(je ne trouve que dc395)
merci aide


Numéro de l'article: 133180   |  De: joss   |  Date: 2004-09-11 19:32:17
   RE: driver linux
Pourtant sur google.fr/linux ( premiere reponse )
http://www.garloff.de/kurt/linux/dc390/

Sinon, j'ai l'impression que le driver est inclus dans les noyeaux recents

Numéro de l'article: 133193   |  De: phenix   |  Date: 2004-09-11 20:20:40
   RE: driver linux
bonjour,

il fonctionne depuis bien longtemps sans ajouter quoi que ce soit, tekram est connus pour les fournirs avec leurs cartes et il est inclus dans le noyau.
donc l'installation devrait fonctionner sans aucun probléme du moment que ton pc supporte le boot scsi sur CDROM.

Numéro de l'article: 133215   |  De: clucky   |  Date: 2004-09-11 21:27:06
   RE: driver linux
Par contre si tu bootes sur ton dur SCSI, ca marchera pas directement il faut passer par un initrd... En d'autres termes ton noyau ne pourra pas booter à partir du SCSI vu qu'il a besoin du driver et que le driver est ds le noyau, bref, le serpent qui se mord la queue... Donc tu dois créer un ramdisk sur lequel tu mets une mini distrib, et au boot, ton kernel va booter à partir du ramdisk, et la hoo miracle il va pouvoir charger le driver SCSI, et monter le filesystem de ton dur.. le boot continue ensuite à partir du disque...

Numéro de l'article: 133249   |  De: pazcal   |  Date: 2004-09-12 00:09:03
   RE: driver linux
merci

Numéro de l'article: 133991   |  De: joss   |  Date: 2004-09-14 11:41:18

   clôture electrique  
je suis a la recheche du schemat de montage d'une clôture electrique pour mon ane.
mercie

Numéro de l'article: 133181   |  De: arnaud   |  Date: 2004-09-11 19:42:34
   RE: clôture electrique
Bonsoir,

Un schéma sur ce site : http://perso.wanadoo.fr/fo3rj/bricoleur4.htm
egalement sur electronique magazine ; http://www.electronique-magazine.com/som_auto.asp?som=9

peur être d'autres en faisant une recherche sur Google

A+

Numéro de l'article: 133186   |  De: patou149   |  Date: 2004-09-11 20:08:01
   RE: clôture electrique
Qu'est-ce que ton ane va faire avec un schema ? ;-D
amitiés

Numéro de l'article: 133213   |  De: Richard   |  Date: 2004-09-11 21:15:14
   RE: clôture electrique
Richard, tu m'as fait rire.
@+

Numéro de l'article: 133231   |  De: Coro   |  Date: 2004-09-11 23:00:18
   RE: clôture electrique
oui moi aussi :-) elle est bien celle là !
j'adore !

Numéro de l'article: 133261   |  De: nico31   |  Date: 2004-09-12 00:35:12
   RE: clôture electrique
Le schéma qui se trouve sur le site http://perso.wanadoo.fr/fo3rj/bricoleur4.htm
ne convient pas pour une bobine de voiture qui n'a que trois ''accès'' de branchement, la borne ''+'' la borne ''-'' et la sortie HT. Avec un transfo normal c'est différent bien-sûr.
@+

Numéro de l'article: 133266   |  De: Coro   |  Date: 2004-09-12 01:02:33
   RE: clôture electrique
Bonjour,

Dans une bobine d'allumage de voiture la "borne -" correspond au point commun du primaire et du secondaire.
Le schéma modifié, pour T4, le 2N3055 me semble un peu léger, un modèle 400V-10A de type BUX48 est préferable. Pour la diode zener de protection un modèle rapide est conseillée de type transill par ex.
Ne pas oublier de prendre les précaution d'usage quand on manipule sur un montage avce de la THT.

A+
Cliquez ici pour ouvrir l'image


Numéro de l'article: 133390   |  De: patou149   |  Date: 2004-09-12 17:23:24
   RE: clôture electrique
http://www.abcelectronique.com/forum/read.phtml?f=1&i=121360&t=119958

Numéro de l'article: 133568   |  De: Fas54   |  Date: 2004-09-13 10:35:17

   ou acheter des interrupteur de comande au pied a 9  
Bonjours,
je souhaiterais savoir ou acheter des interupteurs de commande au pied a 9 branches. ceux utilises dans les pedales d'effet.

Numéro de l'article: 133190   |  De: upci   |  Date: 2004-09-11 20:18:01
   RE: ou acheter des interrupteur de comande au pied a 9
http://www.wah-wah.co.uk/images/3pdt.jpg

celui la

Numéro de l'article: 133199   |  De: upci   |  Date: 2004-09-11 20:32:18

   Perturbations sur un cable [résolu]  
Bonjour
Je mesure la temperature avec l'ordinateur grace a une interface rs232/i2c.

Le ds1621 est relie a l'interface par un cable de telephone de 5 metres ( cable premier prix, pas de blindage, rien de torsadé ). Si je branche mon interface directement sur le port serie pas de problemes, par contre je le branche avec en plus un cable modem, la ca ne fonctione plus. Cable trop long je supose.

Avant ca fonctionait quand même, mais j'habitait dans une petite residance avec surtout des personnes agées, on peut suposer qu'il n'y est pas trop d'ordinateurs, telephones portables au autre pour perpurber mon signal.

Maintenant je suis dans une grosse residance avec beaucoup de jeunes, donc probablement plus d'appereil qui emettent des ondes.

Pensez vous que ca vienne vraiment de là



Numéro de l'article: 133197   |  De: phenix   |  Date: 2004-09-11 20:28:21
   RE: Perturbations sur un cable
Oui, de variations de champs électro-magnétiques entrainent des interférences. Ya qu'à s'approcher d'un poste de radio avec son téléphone portable pour les entendre!

Numéro de l'article: 133219   |  De: XtremeSpecter   |  Date: 2004-09-11 21:42:52
   RE: Perturbations sur un cable
bjr

le cable de 5 m tu peux l'enrouler et le mettre dans le pC si ca marche ca vient de l'exterieur rayonnement parasite...



Numéro de l'article: 133220   |  De: coco34   |  Date: 2004-09-11 21:45:25
   RE: Perturbations sur un cable [résolu]
Merci des ces reponses. Je ne pense pas que ce soit mon PC qui pose le plus probleme. Car c'est toujours le même.

Il pourait être interesant de visaliser le signal a l'ossiloscope pour voir la tete qu'il a. Mais je n'en possede pas :(

Numéro de l'article: 133294   |  De: phenix   |  Date: 2004-09-12 10:30:27
   RE: Perturbations sur un cable [résolu]
qui te dit que c'est le PC qui deconne ?????



Numéro de l'article: 133338   |  De: coco34   |  Date: 2004-09-12 13:18:05

   mandrin  
je cherche des mandrins a bobiner 8 et 10 mm avec et sans noyau, ou peut on les trouver?
(selectronic n'en a pas).
merci

Numéro de l'article: 133200   |  De: hicham   |  Date: 2004-09-11 20:32:23