ABCelectronique : portail d'information dans le domaine de l'électronique
Home » Diverses rubriques » Archive forum sujets+corp
 
     
   démarrage ATX  
bonjour,
je suis actuellement en train de mettre au point la commande de démarrage d'une alim ATX. est ce que qqun peut confirmer que pour qu'elle démarre il faut que le signal "power on" soit à 5Vstb pdt un court instant.
Je me place ds le cas où l'ATX se connecte sur une carte fond de bus et que la carte FDB redirige les signaux cités sur la carte mère.
Si c pas clair ms que qqun voit de quoi je parle, je préciserai plus.
Merki,
DaVid

Numéro de l'article: 130301   |  De: DaVid   |  Date: 2004-08-31 09:21:07
   RE: démarrage ATX
Salut

C'est l'inverse il faut le mettre à la masse !!

A+


Numéro de l'article: 130304   |  De: Mikaels   |  Date: 2004-08-31 09:31:45
   RE: démarrage ATX
Merci Mikaels d'avoir répondu si vite mais laisse moi un peu plus te situer.
Je vais relier mon connecteur ATX 20 pins à une carte fdb de type PCI. Apres je vais amener mon power on et mon 5Vstb à une carte mere rocky 3702 sur son connecteur control panel.
Et ds la doc il dise que pour allumer l'atx, on peut placer un switch entre le sugnal power on et ce 5Vstb.
Mais ce switch, qd on appuie dessus, ca met power on à 5Vstb, et non à la masse.
tu vois?
David


Numéro de l'article: 130310   |  De: DaVid   |  Date: 2004-08-31 09:43:26
   RE: démarrage ATX
Il est possible qu'au niveau de la CM il y ait une inversion mais en ce qui concerne l'alim le power-on doit être mis à la masse pour démarrer!
Je ne connais pas cette carte je ne peux pas t'en dire plus !


Numéro de l'article: 130313   |  De: Mikaels   |  Date: 2004-08-31 09:50:50
   RE: démarrage ATX
Ce message est pour le webmaster,
je suis conscient du caractere pirate de mon sujet mais il ne l'est absolument pas. je suis stagiaire et je recherche une aide pour ne pas faire de betises. ce n'est pas pirate car il existe des alims ATX de type industrielle avec les arrivées secteur à base de cosses afin de les connecter à une carte qui commande son démarrage et son extinction. Ces alims sont normées CE et donc l'emploi que je veux en faire n'est absolument pas pirate.
Sachez que je me ferai un réel plaisir en tt que futur ingénieur électronique à répondre aux posts qui me sont accessibles.

merci de votre compréhension.
DaVid


Numéro de l'article: 130316   |  De: DaVid   |  Date: 2004-08-31 09:55:17
   RE: démarrage ATX
merci bcp Mikaels je vais me rencarder.
Je tiendrai au courant le forum qd j'aurai acquis mon atx et que je l'aurai démarré.
à plus,
DaVid

Numéro de l'article: 130319   |  De: DaVid   |  Date: 2004-08-31 09:57:31
   RE: démarrage ATX
Bonjour,

Toujours la même image mais qui permet de s'y retrouver !

a+

Numéro de l'article: 130367   |  De: Coro   |  Date: 2004-08-31 11:33:20
   RE: démarrage ATX
salut Coro,
g pas compris ce que tu voulais dire,
DaVid

Numéro de l'article: 130373   |  De: DaVid   |  Date: 2004-08-31 11:49:21
   RE: démarrage ATX
Oups, pardon.

Numéro de l'article: 130631   |  De: Coro   |  Date: 2004-09-01 00:19:17
   RE: démarrage ATX
Voilà,


Cliquez ici pour ouvrir l'image


Numéro de l'article: 130632   |  De: Coro   |  Date: 2004-09-01 00:19:55
   RE: démarrage ATX
Salut coro,
merci
je connais bien cette image.
Mais ma question dans mon post ne concernait pas venir manipuler à partir du connecteur ATX. J'ai pu lire sur des forums que c'est fotement déconseillé.
Ma question, c t en fait ds le cas où on a une carte fond de bus et que c'est à partir de cette carte fond de bus qu'on redirige les signaux de démarrage vers la carte mère et de là qu'on peut les commander.
Je comprends que mon pb est tres spécifique. Mais je m'embrouille avec le Power Good, PS ON, power on...

Est ce que qqun se sent de faire un résumé?

DaVid

Numéro de l'article: 130660   |  De: DaVid   |  Date: 2004-09-01 09:08:21

   Thermostat chauffe-eau  
Le thermostat chauffe-eau fonctionnait la semaine dernière. Puis, cette semaine, plus de jus à la sortie du thermostat. j'ai tourné le réglage mais rien n'y fait.
Y aurait-il quelqu'un pour me dire si on peut ouvrir le boitier du thermostat et le dépanner.
S'agit thermosta réf.TRS/77 pour chauffe-eau ISEA 50litres

Numéro de l'article: 130315   |  De: rabe   |  Date: 2004-08-31 09:55:13
   RE: Thermostat chauffe-eau
tu gagnera dans tous les cas a l'ouvrir, soit tu trouve le probleme, soit tu trouve pas et tu le change.
voila
@+

Numéro de l'article: 130332   |  De: atheman   |  Date: 2004-08-31 10:20:24
   RE: Thermostat chauffe-eau
Salut
En general il y a un thermique sur le thermostat.Regarde bien si tu ne vois pas un petit bouton rouge,tu appuis dessus ca dois faire un petit clic
a+

Numéro de l'article: 130342   |  De: docR   |  Date: 2004-08-31 10:43:33
   RE: Thermostat chauffe-eau
Salut,
chez Conrad ( www.conrad.fr ), tu vas trouver un thermostat de rechange
( environ 15 Euros ). J' ai réparé mon chauffe-eau le mois dernier.
A+
http://perso.wanadoo.fr/remy-p/

Numéro de l'article: 130501   |  De: Rémy   |  Date: 2004-08-31 17:41:10
   RE: Thermostat chauffe-eau
J'ai cliquer sur le bouton rouge et la conexion est établie;mais malheur, le thermostat ne veut plus fonctionner correctemen en fonction de la température.
Pendant 6 heures, le chauffe-eau n'arrêtait pas de fonctionner (témoin rouge allulé).Puisfinalement, j'ai coupé le jus car le jaugeur température, commençait aller au max.
Que faire: démonter le thermostat pour voir? Merci de me dépanner.
Rabe

Numéro de l'article: 130964   |  De: rabe   |  Date: 2004-09-02 12:41:07
   RE: Thermostat chauffe-eau
re
ta resistance est peut etre saturée par le calcaire,demonte le tout et nettoie l'interieur du cumulus (recommandé d'ailleur tout les x temps suivant la dureté de l'eau de ta region)
a+

Numéro de l'article: 130989   |  De: docR   |  Date: 2004-09-02 13:39:52
   RE: Thermostat chauffe-eau
1/ Cet apparaeil a été peu utilisé: est-ce possible qu'il y a du calcaire étént très peu utlisé?

3/ Le bouton de réglage du thermostat a plusieurs possiblités pour régler en ce qui concerne le bouton blanc de réglage du thermostat.
Peu^t-être, il faudrait voir de ce côté avant de démonter.

2/ Comment démonter: je ne l'ai jamais fait (s'agit d'un ISEA, Italie)
Est-ce que cela n'abîme pas la résistance?

Merci, rabe

Numéro de l'article: 131180   |  De: rabe   |  Date: 2004-09-03 11:51:42
   RE: Thermostat chauffe-eau
a savoir qu'il y a des region tres calcaire et qu'un nettoyage est necessaire tout les 2 ans
le bouton de reglage sert uniquement a regler la temperature de l'eau,tu peut le monter je ne pense pas que ca resoudra ton pb.
Pour demonter ,tu coupe l'arrivée d'eau sur le groupe de securite ou l'arrivée principale si celui ci est grippé,ouvrir la soupape de securite a l'aide du petit levier,demonter un raccord de sortie de l'eau chaude pour laisser rentrer de l'air,une fois le ballon vide tu demonte le flasque (la ou est fixé le thermostat)6 ou 8 vis avec une cle de 13 (en general)et tu sort le tout.Ca peut coincer un peu si trop de calcaire sans oublier de couper l'alimentation elec.
a+

Numéro de l'article: 131211   |  De: docR   |  Date: 2004-09-03 14:11:05

   alim de labo Sytron M107  
salut a tous
quelqu'un peut-il me dir ou puis je trouver la doc ou le schema d'une alim de labo de marque sytron donner model m107.malgres toutes mes reche sur internet aucune n'a abouti.
merci d'avance.

Numéro de l'article: 130329   |  De: rebel   |  Date: 2004-08-31 10:14:14

   Ecran floue TV Océanic  
J'ai TV,marque Océanic 31 3300, base technique U13 1042
Les fonctions lumière, contraste, couleur fonctionne parfaitement. Mais l'écran donne une image floue: J'ai changé la résistance 2M2 par des résistances carbone de G2, d'une valeur approximative en mettant en série les résistances. (car la résistance d'origine n'est plus en vente).J'ai pu obtenir la tension G 300/500 V, la concentration est normale 8kV.

Merci de m'indiquer d'où vient cette image floue et de m'informer comment obtenir une image correcte.

Numéro de l'article: 130334   |  De: rabe   |  Date: 2004-08-31 10:26:41
   RE: Ecran floue TV Océanic
As-tu tenter de régler le focus avec potar du haut sur la THT?

A+

Numéro de l'article: 130353   |  De: pym   |  Date: 2004-08-31 11:07:50
   RE: Ecran floue TV Océanic
Eh oui j'ajoute un peu sur l'idée déja avancée. Regarde au niveau du tht, tu verra 2 focus pour lr reglage de ton ecran

Numéro de l'article: 130492   |  De: hoby   |  Date: 2004-08-31 17:29:07
   RE: Ecran floue TV Océanic
Sur la TV en question, les potar focus et screen sont implantés sur le module circuit tube.
Il s'agit de potar 34 mégohm et 2.2 mégohm.
J'ai fait leur réglage suivant le shéma du constructeur, mais l'image floue est toujours là.
En plus, l'image sur l'écran est un peu étirée dans le sens horizontal.
Que faire pour rendre l'mage nette et régler cet étirement.
Merci

Numéro de l'article: 130968   |  De: rabe   |  Date: 2004-09-02 12:49:54
   RE: Ecran floue TV Océanic
Bonjour

Idée:

Vérifie si la tension d'alimentation de ton BU (ce que l'on appelle le 145V(qui peut varier selon les TV)) est à sa bonne valeur, vérifie aussi (si tu sais ) ta THT (il te faut un multimètre avec un probe THT).

Tu dis avoir changé la valeur des R de la focalisation ? Tu est donc à butée dans un sens ou dans l'autre >> diminuer la résistance du coté de cette butée !?

A bientôt

Numéro de l'article: 131013   |  De: EPERVIER   |  Date: 2004-09-02 15:08:07
   RE: Ecran floue TV Océanic
L'image étirée dans le sens H m'inciterait à remplacer le(s) condos de récup entre collecteur et emetteur du BU ligne (qq nF 1600V)...

A+

Numéro de l'article: 131034   |  De: pym   |  Date: 2004-09-02 16:19:22
   RE: Ecran floue TV Océanic
L'image étirée dans le sens H m'inciterait à remplacer le(s) condos de récup entre collecteur et emetteur du BU ligne (qq nF 1600V)...

A+

Numéro de l'article: 131035   |  De: pym   |  Date: 2004-09-02 16:19:24

   TV GRUNDIG 70cm qui fume....  
Bonjour à tous.

J'ai une TV GRUNDIG 70cm qui a maintenant plus de 10 ans.
Hier, elle s'est mise à grésiller et l'image a été fortement parasitée.
Une fumée s'est échappée de l'arière de la TV.
Depuis, je ne l'ai bien évidemment pas rebranchée et je l'ai démontée.
Apparemment ça viendrait de la platine electronique fixée à l'arrière du tube cathodique. (voir les photos)

Qui peut me dire si elle est HS ou si elle est réparable ?
Quel budget approx pour les pièces ?

Ca serait simpa.

Merci d'avance !

PS: Dans ce premier post, une photo vue générale et dans le suivant, une photo en gros plan du composant qui a l'ir d'avoir souffert...
Cliquez ici pour ouvrir l'image


Numéro de l'article: 130336   |  De: Pascalibus   |  Date: 2004-08-31 10:36:44
   La photo en gros plan...
La photo en gros plan :
Cliquez ici pour ouvrir l'image


Numéro de l'article: 130337   |  De: Pascalibus   |  Date: 2004-08-31 10:37:48
   RE: La photo en gros plan...
Déja un bon coup d'aspirateur.
La pièce incriminée est un ensemple de potentiomètre pour le réglage de focus, reste à la trouver et s'il n'y a que ça, c'est pas grave.
Modèle exact du TV ou type de chassis ?

Numéro de l'article: 130340   |  De: Fas54   |  Date: 2004-08-31 10:41:36
   RE: La photo en gros plan...
C'est vrai que le coup d'aspirateur est... indispensable ;)))

Le modèle exact du téléviseur: (étiquette papier sur le chassis)

GCV5081FBF
ST 70-675.
403477

Il est équipé d'un tube philips.

J'ai débranché dès qu'il y a eu des grésillements mais j'ai bien peur que les dégats soient plus important que ce simple jeu de potars non ?


Numéro de l'article: 130345   |  De: Pascalibus   |  Date: 2004-08-31 10:49:25
   RE: La photo en gros plan...
Chassis CUC5360.
A contrôler également C716, R712.

Cliquez ici pour ouvrir l'image


Numéro de l'article: 130354   |  De: Fas54   |  Date: 2004-08-31 11:08:20
   RE: La photo en gros plan...
Un grand merci pour tout.
Il ne me reste plus qu'à dénicher le composant...

Tu as une adresse ?

Peut être qu'il serait plus simple de changer la platine complète ?

Numéro de l'article: 130357   |  De: Pascalibus   |  Date: 2004-08-31 11:12:41
   RE: La photo en gros plan...
Pièces TV chez http://bpt31.free.fr/index.html

Numéro de l'article: 130386   |  De: bibi2030   |  Date: 2004-08-31 12:15:35

   tele s allume plus  
bonjour

ma tele (philips 36 cm 10 ans) ne s allume plus depuis que le disjoncteur a saute lors d´un orage.
le demodulateur marche lui encore tres bien.
est ce possible pour quelqu'un qui s´y connait un peu en electronique mais pas forcement en tele de trouver la panne?
je pense a un probleme de fusible... est ce que quelqu'un aurait une petite idee?

Merci d´avance.
.

INFO et RAPPEL :
Ce message a été corrigé.
Sur ce forum, les messages style SMS vont directement à la poubelle.

Numéro de l'article: 130338   |  De: bibe   |  Date: 2004-08-31 10:38:58
   RE: tele s allume plus
Comment sais tu que le demod marche encore...? Si c'est un fusible, tu n'as plus rien, ni son ni image, ni affichage, etc etc....



Numéro de l'article: 130350   |  De: pazcal   |  Date: 2004-08-31 10:59:53
   RE: tele s allume plus
ben en fait le demodulateur s allume encore alors que la tele plus rien. meme la led (indication que la tele est allume) s allume plus.
donc oui j'ai plus d image,plus de son...etc

merci pour ton aide



Numéro de l'article: 130352   |  De: bibe   |  Date: 2004-08-31 11:04:03
   RE: tele s allume plus
ha oki, c'est pas le demod integre dans le TV... Ben ouvre, et verifie le fusible... Si ca n'a pas senti le cramé lorsque le disjoncteur a sauté, c'est qu'il a été assez rapide pour pas fire cramer ton poste... Et ds ce cas, c'est sans doute le fusible...
bonne chance

Numéro de l'article: 130369   |  De: pazcal   |  Date: 2004-08-31 11:38:18
   RE: tele s allume plus
ok j´essaierai de faire ca ce soir.
merci

Numéro de l'article: 130382   |  De: bibe   |  Date: 2004-08-31 12:07:46
   RE: tele s allume plus
Il peut y avoir d'autres dégâts derrière !

Numéro de l'article: 130385   |  De: bibi2030   |  Date: 2004-08-31 12:12:13

   moteur mono 5 fils  
bonjour
on ma donne un moteur de machine a laver
5 fils bleu,rouge noir blanc jaune
plus un condensateur 12.5 a 4 broches
j aimerai connaitre le schema de branchement
(moteur de machine candy)
merci beaucoup ,cela va m'aider a brosser 80 metres carre de tomette

A+
Cliquez ici pour ouvrir l'image


Numéro de l'article: 130343   |  De: pascal   |  Date: 2004-08-31 10:48:15
   RE: moteur mono 5 fils
salut
y a t il quelque chose de marque sur le moteur?
pour le condo 2*2contacts (2 contacts pour la meme borne)
semopy




Numéro de l'article: 130361   |  De: semopy   |  Date: 2004-08-31 11:20:51
   RE: moteur mono 5 fils
Arf,

les moteur de machine a laver...

A mon avis, ce moteur datte d'une machine ou les variateur electronique n'etait pas chose commune... Donc, tu dois avoir 1 fil pour le commun, 1 fil pour le condos, et te reste 3 fils qui te permettent de faire varier la vitesse du moteur, en mettant en serie plus ou moins de bobinage...

Le meiux, serait de retrouver le schéma de la machine a laver en question pour retrouver le branchement du moteur...

Dans le temps , les schéma etait livré avec la machine...

Numéro de l'article: 130590   |  De: dspix   |  Date: 2004-08-31 21:45:34
   RE: moteur mono 5 fils
bonjour

Voic le schéma mais à toi de retrouver les couleurs !
C'est en fait un moteur avec deux bobinages distincts

1 pour le lavage avec beaucoup de pôles pour une rotation lente
1 pour l'essorage avec 1 paire de pôles pour une rotaion rapide.

On utilise le même condensateur pour les deux vitesses et la vitesse rapide n'a normalement qu'un sens de rotation. donc son pôle (enroulement de déphasage) a une résistance plus grande. Ceux (les enroulements)de la vitesse lente ont la même résistance.
Fas 54 avait ,je crois,donné le schéma de raccordement ??
A bientôt
###Graphgr_1957###

Numéro de l'article: 130786   |  De: EPERVIER   |  Date: 2004-09-01 16:41:40

   AD654 volt->fréquence  
Bonjour,
Est-ce que par hasard qqun aurait déjà utiliser ce composant et pourrait me confirmer cela:
Je souhaite faire varier une tension entre 0 et 5V de manière à faire varier en sortie une fréquence de 0 à 10kHz avec un signal de type ttl en sortie.
Est-ce que cela est possible: apparemment, oui selon la datasheet mais je ne suis pas sûre de bie, savoir dimensionner les composants R et C autour: est-ce que si je prends R (=R1+R2 dans la datasheet) =500ohms et C=1µF cela conviendrait-il. Pour trouver j'ai utiliser la relation p.4 de la datasheet sur la figure n°1....

Merci d'avance!

http://.com/datasheet-pdf/pdf/AD/AD654JN/datasheet.pdf


Numéro de l'article: 130346   |  De: pa'doué   |  Date: 2004-08-31 10:50:19
   RE: AD654 volt->fréquence
Bonjour,

Attention il est indiqué dans le datasheet que le courant doit être de 1mA pour VEmax, donc dans ton cas R=5Kohms et suivant la formule C = 10nF.
A+

Numéro de l'article: 130366   |  De: patou149   |  Date: 2004-08-31 11:32:17

   PCF8583 fonctionnant à moitié !  
Salut à tous,

j'ai une PCF8583 que je pilote sans soucis en I2C
le seul truc c'est que j'ai l'impression que mon quartz n'oscille pas ! en effet l'heure n'avance pas. si je place mon oscilo sur le quartz et que je regarde l'heure, celle-ci avance ... en gros ma sonde influe sur le comportement du quartz .

Que faire ?

voici une photo du montage piqué sur le web !
la fleche rose correspond à ma sonde.
Cliquez ici pour ouvrir l'image


Numéro de l'article: 130360   |  De: altahir007   |  Date: 2004-08-31 11:20:05
   RE: PCF8583 fonctionnant à moitié !
La sonde ajoute sa propre capacité et l'oscillateur démarre...donc chercher du coté des capacités à mettre en place de chaque coté du quartz ou valeur à modifier (on ne voit pas de schéma!)

A+

Numéro de l'article: 130363   |  De: pym   |  Date: 2004-08-31 11:22:05
   RE: PCF8583 fonctionnant à moitié !

Merci Pym pour ton explication, je pensais qu'une sonde n'avait qu'une resistance quasi infinie mais pas de capa :( c'est de quel ordre tu sais ?

je vais essayer avec deux condo à la place d'un !
pour la valeur tu veux que j'essaie de mettre la moitiée ? j'ai un condo de 27pF pour le moment !

Numéro de l'article: 130364   |  De: altahir007   |  Date: 2004-08-31 11:25:52
   RE: PCF8583 fonctionnant à moitié !
Bonjour,

Une sonde de scope à une capacite de l'ordre de 10pF.
Attention la valeur de la capa sur le PCF modifie la fréquence du quartz.

A+

Numéro de l'article: 130372   |  De: patou149   |  Date: 2004-08-31 11:48:09
   RE: PCF8583 fonctionnant à moitié !
ça marche nikel avec un condo variable de 3-30pF !
merci encore pour ton aide pym (tu as l'ordre de grandeur de la sonde d'un oscilo ?)



Numéro de l'article: 130374   |  De: altahir007   |  Date: 2004-08-31 11:49:37
   RE: PCF8583 fonctionnant à moitié !
oups pas vu la reponse de patou149 !

MERCI pour vos infos !

Numéro de l'article: 130375   |  De: altahir007   |  Date: 2004-08-31 11:50:08

   Ajout de mémoire au pic-basic 3H ? C possible ça ?  

INFO et RAPPEL :
Ce message a été supprimé.
Sur ce forum, les messages style SMS vont directement à la poubelle.
Faites l'effort d'écrire correctement de façon claire et compréhensible par tous.


Numéro de l'article: 130370   |  De: 2iki   |  Date: 2004-08-31 11:40:52

   RS232 et I²C  
Bonjour

Je voudrais commander des montages electronique avec mon PC par le port serie. Je me suis renseigner sur les protocole RS232 et I²C et en ai deduis que le plus simple d'utilisation est le I²C.
Mais un PC peut-il utiliser ce protocole ?
Si oui, quelqu'un connait-il un site ou il est expliquer comment l'utiliser avec Visual Basic 6.0 ?

Merci beaucoup

Numéro de l'article: 130377   |  De: Benji   |  Date: 2004-08-31 11:59:00
   RE: RS232 et I²C
regarde a http://perso.club-internet.fr/mbouget
tu a le schema de l'interface, les driver et des exemple en vb

Numéro de l'article: 130396   |  De: Flo   |  Date: 2004-08-31 12:52:28
   RE: RS232 et I²C
slt

il te faut de toute façon une interface pour générer les signaux du bus i2c, (ci joint interface simple)ce n'est pas possible directement à partir du pc, ensuite tu pourras piloter des composants i2c, comme tu programmes en visual basic tu n'auras certainement aucun probleme pour faire des trames i2c, jette un oeil sur le protocole de communication
pour la com rs232 je suis etonne que tu la trouve compliquée, elle n'est pas plus compliqué que l'i2c, je ne connais pas visual basic, (perso builder c++) mais il doit exister des objets preprogrammés pour rs232, en builder c++ j'ai rajouté l'objet tcomport qu'on trouve sur developpez.com et il suffit de remplir les champs vitesse parité nombre de bits etc.. pas de programmation api donc facile a utilise et le protocole asynchrone rs232 c'est pas compliqué
si tu ne possedes pas d'objet de ce type une petite recherche sur developpez te fournira une source d'objets importante

http://perso.easynet.fr/~chrisg/busi2.htm

slt

Numéro de l'article: 130400   |  De: frost   |  Date: 2004-08-31 13:05:17
   RE: RS232 et I²C
Hello voilà encore un

Si tu réalises celui-ci donne moi des nouvelles concernant sont bon ou mauvais fonctionnement!!

http://www.riccibitti.com/pc_therm.htm

Numéro de l'article: 130402   |  De: THT   |  Date: 2004-08-31 13:07:33
   RE: RS232 et I²C
ops je viens de visiter les 2 autres mais sans aucun doute que ce dernier lien sera le + approprié (:|

Numéro de l'article: 130403   |  De: THT   |  Date: 2004-08-31 13:09:46
   RE: RS232 et I²C
bien cool ton lien THT, je prends :)

Numéro de l'article: 130405   |  De: frost   |  Date: 2004-08-31 13:12:34
   RE: RS232 et I²C
J'utilise le ds1621 avec un montage perso proche du lien de THT, ca fonctione normalement

Numéro de l'article: 130417   |  De: phenix   |  Date: 2004-08-31 13:46:41
   RE: RS232 et I²C
Merci a tous !!
En fait je trouve le RS232 "compliquer" car le seule moyen de savoir quand lire un bit, c'est de "chronometrer"... Alors que l'I²C (si j'ai bien compris) on a juste a lire quand un signal est envoyé sur une autre broche...
D'ailleur pour le RS232 il n'y a bien que 2 broche (data + masse) ?
Et pour le I²C il y en a 3 (data + clock + masse) ?
Mais surement existent-ils des "convertisseur" (est la meme chose que interface ?) RS232 <-> I²C ?
J'utilise des µC Atmel (AT90S2313). Est-il facile de les faire communiquer avec le PC en RS232 (sachant qu'il ne possedent aucune interface)?

Merci beaucoup

PS : voici un lien pour le RS232 en VB : http://grafikm.developpez.com/portcomm/


Numéro de l'article: 130461   |  De: Benji   |  Date: 2004-08-31 16:01:12
   RE: RS232 et I²C
Si, le AT90S2313 possède un UART full duplex....

Numéro de l'article: 130484   |  De: Adrien   |  Date: 2004-08-31 17:05:02
   RE: RS232 et I²C
deja t'as deux types de transmissions differentes
i2ctransmission synchrone on transmet une horloge et on synchronise les donnees par rapport a l'horloge
rs232 la transmission est asynchrone il n'y a pas d'horloge transmise
on detecte un bit de depart...un stop etc
erreur >rs232 rx tx et masse ça fait trois fils pour pouvoir transmettre.
convertisseur inutile, il faut ectroniquement avoir les bons signaux
ce que permet un montage simple (montage tht)ou le montage sur port parallele et puis ecrire le protocole n'importe quel langage le permet

>phenix le montage sur port // fonctionne aussi normalement heureusement !!
beaucoup de choses d'ailleurs c'est rassurant :)

Numéro de l'article: 130486   |  De: frost   |  Date: 2004-08-31 17:11:29
   RE: RS232 et I²C
je ne connais pas l'atmel d'apres adrien y'a un UART donc pour communiquer avec un pc il "suffit" d'utiliser un max232 pour mettre les signaux rs232 au niveau logique (0,5v) et tu peux transmettre
pour atmel assembleur ?
du côté atmel la gestion du protocole est peut être un peu plus lourde que du côté visual basic (quoique).

slt


Numéro de l'article: 130561   |  De: frost   |  Date: 2004-08-31 20:15:48
   RE: RS232 et I²C

benji
ci joint
j'tai trouvé un truc interessant

http://www.ap2c.org/index.php?page=montage_interface_pc_i2c

Numéro de l'article: 130564   |  De: frost   |  Date: 2004-08-31 20:38:32
   RE: RS232 et I²C
Merci a tous !
Effectivement le AT90S2313 possede une UART... Et cela regle tout mes probleme ! Sauf pour les signaux logiques : en lisant les docs, je crois que le niveau 1 (+5V) est a -12V pour le RS232 et le 0 (0V) est a +12V ?...

Merci beaucoup a tous
a+
Benji

Numéro de l'article: 130653   |  De: Benji   |  Date: 2004-09-01 08:00:49
   RE: RS232 et I²C
lis bien les reponses benji :)

Numéro de l'article: 130655   |  De: frost   |  Date: 2004-09-01 08:18:53

   Questions sur emetteur HP 8620A SWEEP OSCILLATOR  
Bonjour.
J'ai récupéré un emetteur en rack 19' de référence HP 8620A SWEEP OSCILLATOR. A Priori il s'agit d'un emetteur de forte puissance capable d'emettre dans les tres tres hautes fréquences (j'usqu'à 4,2 GHz).Je voudrais savoir si quelqu'un connait ce produit, comment cela fonctionne et si c'est possible d'emettre avec sur des bandes comprises entre 1 et 100 Mhz ? (Modification de quartz ???) Je vous remercie d'avance !!!
Cliquez ici pour ouvrir l'image


Numéro de l'article: 130383   |  De: Trance.Metteur   |  Date: 2004-08-31 12:09:27
   RE: Questions sur emetteur HP 8620A SWEEP OSCILLAT
Salut

Ce n'est pas un émetteur mais un générateur sweeper. La différence majeure vient de ce qu'il n'est pas spécialement stable en fréquence; suffisamment pour conduire des test RF sur des équipements large bande mais pas assez pour être utilisé en temps que pilote émission; Pour cela, il faut un générateur synthétisé ce qui n'est pas le cas du 8620. Sa puissance de sortie est seulement de qq mW (de mémoire), ce qui reste très insuffisant pour faire directement du Tx; il faut lui ajouter un ampli de puissance. Ce second "défaut" est nettement moins problématique que le manque de stabilité.

A=

Numéro de l'article: 130390   |  De: SuperPapum   |  Date: 2004-08-31 12:29:31
   RE: Questions sur emetteur HP 8620A SWEEP OSCILLAT
Je te remercie pour toutes ces informations. Si quelqu'un est interessé, proposez vos prix !

Numéro de l'article: 130397   |  De: Trance.Metteur   |  Date: 2004-08-31 12:57:03
   RE: Questions sur emetteur HP 8620A SWEEP OSCILLAT
salut

tu a par hasard le mode d'emploi et le schéma de cet appareil car j'en ai un mais sans docs pour l'utilisé pour une idée de prix g acheter le mien environ 350 Euros matos en bon état et peu servi à+

Numéro de l'article: 130897   |  De: fred   |  Date: 2004-09-02 00:54:56
   RE: Questions sur emetteur HP 8620A SWEEP OSCILLAT
Désolé je l'ai tel que !!! Sans rien du tout !!!

Numéro de l'article: 130944   |  De: Trance.Metteur   |  Date: 2004-09-02 11:25:11